QTerminal freezes (Lubuntu 20.04)

Whenever I enter a sudo command in QTerminal e.g “sudo -i” and press enter I am asked to enter my password but can’t type anything because QTerminal has frozen.

I have tried reinstalling QTerminal but it still freezes at the password prompt. I have also installed another copy of Lubuntu 20.04 on a USB stick but have the same problem with that installation too.

What do you mean with frozen? Can you open the “File” menu with the mouse?
What happens, if you type a wrong password and hit Enter?
What happens, if you type the right password and hit Enter?
What happens, if you abort it with CTRL+D?

1 Like

Thanks for your reply

I mean that I get as far as below but then the cursor (marked by “_”) freezes so I can’t type my password or anything at all including a wrong password.

david@david-inspiron5559:~$ sudo -i
[sudo] password for david: _

I can press enter however and I get to as below but then the cursor freezes again.

david@david-inspiron5559:~$ sudo -i
[sudo] password for david: _
Sorry, try again.
[sudo] password for david: _

If I use CTRL+D, I get as below and then use CTRL+D again I get a confirmation box asking me if I am sure I want to exit.

david@david-inspiron5559:~$ sudo -i
[sudo] password for david:
sudo: no password was provided
david@david-inspiron5559:~$

Yes I can open the “File” menu etc with my mouse and right clicking inside the terminal works too.

Looks normal, it is not frozen.

Type the password, hit enter and go on with whatever you need to do.

1 Like

I thought that I had explained - I can’t type anything at the password point. That’s the whole problem. I try typing and nothing happens. The cursor remains stuck at the password prompt. The only keystroke which moves the cursor is enter.

How I wish I could just “Type the password, hit enter and go on with whatever” I need to do! I am having to abandon Lubuntu because of this problem and go back to Linux Mint. I can type away to my hearts content in it’s terminal including “Type the password, hit enter and go on with whatever” I need to do. Same with Zorin etc. Just not Lubuntu’s terminal.

Update!
Just come across:

https://bugs.launchpad.net/ubuntu/+source/lxqt-admin/+bug/1875774
and
https://discourse.lubuntu.me/t/no-authorization-after-adding-user/1033/

Apparently it’s a problem affecting user’s permissions when doing a fresh install of Lubuntu 20.04 and the way around it is to install version 19.10 and update from there. I’ll give it a try and hopefully I will be able to stick with Lubuntu as I really like it!

If it’s working, you should see nothing display at the password prompt as you type your password. That is expected behavior (in case someone, or a camera is looking over your shoulder at the screen).

Your password is noted & acted upon if correct, or you get errors if incorrect. Not being displayed is done for security reasons.

Not so I am afraid. Of course I have tried just typing my password at the prompt and pressing enter.

Do your circumstances match the circumstances in the bug report you mention.

Alas I’m not a good writer so my language isn’t always understandable, but that bug report took me awhile to re-create (from the support detail here), and was something I couldn’t re-create if I did those tasks as I would using the system as I’d normally do it.

If you believe it does match, please add yourself to that report (ie. click the affects me too link) and let me know, I’ll have to do some more testing with it. (It’s been in my to-do list awhile and not gotten any attention, I’ll endeavor to change that)

Thanks. I had already suspected that it might be a problem with my user permissions so I will try installing 19.10 and update to 20.04 from there and let you know the outcome.

Hi Just to update you, it turned out to be a permissions problem. I tried to add permissions to my user profile such as root but the changes weren’t being saved. However that changed after the last update and the changes were saved so I didn’t need to install 19.10 and update from there in the end.

1 Like