Putting Google Remote on 18.04.6 on HP ProDesk 400 PC kills keyboard and mouse

Why does installing Google Remote Desktop in Lubuntu 18.04.6 on HP ProDesk 400 PC stop keyboard and mouse working?

On five other PCs and laptops this problem does not occur – it just affects the HP ProDesk 400.

I’ve tried 4 clean installs of the OS and then installed remote desktop. Every time the OS and Remote Desktop work fine until the computer is switched off.

After rebooting, the keyboard and mouse are both disabled and totally inoperative. The LED under the mouse is on but the keyboard num lock and caps lock lights do not come on.

A ClamTK scan of the whole installed filesystem, after installing Remote Desktop, finds no threats.

Please can anyone help?

Not sure about that. Lubuntu support for 18.04 ended a long time ago though, so might not be able to do much on this side.

From what I see in Google’s help site, there are many odd reports of irregularities for this on Linux as well.

You might have better luck asking on their site but they might just circle you back here.

I’ve moved this to off-topic as Lubuntu 18.04 LTS reached EOL some time ago, please refer to https://lubuntu.me/bionic-eol/

You can use ubuntu-support-status to confirm what packages still get Ubuntu support & security fixes if security matters to you (repositories remain open during standard support [ie. till April 2023] so MOTUs can still fix issues even if teams have ended their support), as has been documented elsewhere on this site too.

Many thanks for your reply. I’ve abandoned Chrome Remote Desktop for TeamViewer which works perfectly and does not interfere with the operation of the computer. So please close my request for help and delete my post. Kind regards, David

2 Likes