Problems with DNS [SOLVED]

My /etc/resolv.conf contains some old entries that I think broke my DNS.
It’s interesting that the nm-tray does not show the bad IPs.

What would cause the operation not permitted?
I booted off USB and my nvme file systems have no errors.
It is ext4fs.

$ ls -l /etc/resolv.conf
-rw-r--r-- 1 root root 50 Feb  9  2022 /etc/resolv.conf

$ sudo rm /etc/resolv.conf
rm: cannot remove '/etc/resolv.conf': Operation not permitted

$ sudo -s
# chmod a+w /etc/resolv.conf
chmod: changing permissions of '/etc/resolv.conf': Operation not permitted

Try the following command (with sudo or as root) and then see if you can edit:

chattr -i /etc/resolv.conf

1 Like

Did the chattr command and then I got rid of /etc/resolv.conf but I had no DNS servers despite the nm-tray app saying I did.

I did
$ sudo resolvectl revert wlp0s20f3 (my wifi interface)
and rebooted and it works now.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.