Problem after updating, and freeze during the update... thx for the help im in big despair

Hello everyone !
lubuntu suggested to update my version to 20.04, i let it do but the pc froze during the update.
after letting the freeze during 2 hours , i decided to force reboot with the button, i dont think i had other solution, i tried to ssh but it didnt worked.
Now at the boot i have

[27.176487] blk_update_request: I/O error, dev fd0 sector 0 op 0x0:(READ) flags phys_seg 1 prio class 0
[39.448587] blk_update_request: I/O error, dev fd0 sector 0 op 0x0:(READ) flags phys_seg 1 prio class 0
[51.722367] blk_update_request: I/O error, dev fd0 sector 0 op 0x0:(READ) flags phys_seg 1 prio class 0

despite this error i still can connect to my session with ssh from an other computer

also if choose ubuntu(recovery) on grub, i can have access to the terminal but i lost the gui.

I really hope pc is not too damaged, im a super newbies with those linux stuff.
Hope you can help me.

Thanks a lot in advance u.u

the pc is super old its a core2quad intel with 2go ram
i use it as a nas server with gui.
and even with the error i still have access to my hdd…
this is crazy
i suspect a problem with the gui dmlight or grub but actually i really dont know i tried with ssh apt update / upgrade hoping it would finish an eventually broken update but it didnt solve my problem

Update/upgrade from what?

These messages meaning nothing, except the floppy drive your BIOS says your box has, doesn’t contain a valid floppy disk (ie. insert a floppy disk in the drive & you’ll not get the messages any longer, but you’ll instead hear your floppy drive spin up & access the floppy.)

ps: Note I’ve see(n) these messages on boxes that don’t actually have floppy drives, but because the BIOS has capacity to have one, the OS is told there maybe one thus scans the floppy & gets the error (inability to read floppy fd0). If you box doesn’t have a floppy drive, you maybe able to disable the floppy search via BIOS settings, but it’s not always possible in my experience.

I won’t provide more as update from what is rather critical.

1 Like

sorry
updated from lubuntu probably the previous version 19.04

i just realise that i can access the command line, those line just show up after the login: but i can write my login and password after this and enter my session, could you tell me how to enable lightdm again? im really not confident with this and afraid that my ssd could be corrupted with all those freeze during the update

if you have some recommendation i would like to hear it

Lubuntu 19.04 was not the previous release, Lubuntu 19.10 was.

Lubuntu 19.04 had one intended upgrade path, to the next release which was Lubuntu 19.10, from 19.10 you could upgrade to Lubuntu 20.04 LTS as a QA-tested & fully supported upgrade path.

Upgrades from 19.04 however were only QA-tested to upgrade to 19.10 being the only supported upgrade path. Yes some CI package testing is performed for all upgrades paths, but that doesn’t guarantee avoiding issues as it’s not QA-tested/supported.

Ubuntu 19.04 reached EOL in January 2020 and given how long ago that was, I’d likely upgrade via re-install.

I suspect though you weren’t on 19.04 though, but something else so I’d suggest checking. Lubuntu 19.04 was two releases prior to 20.04; was it 19.10 the previous release?

If it was Lubuntu 18.04 LTS however problems are to be expected, which is why the upgrade from 18.04 to 20.04 is not supported for Lubuntu. Refer the release notes

Note, due to the extensive changes required for the shift in desktop environments, the Lubuntu team does not support upgrading from 18.04 or below to any greater release. Doing so will result in a broken system. If you are on 18.04 or below and would like to upgrade, please do a fresh install.

Lubuntu hasn’t used lightdm in the last six releases, it was last used in 18.04 where upgrades are unsupported without install.

Is it possible to check the history of previous version with a specific command line? im really not sure about which version i came from, but the update to 20.04 was suggested by the os itself.
aren’t the problem have more chances to ccome from the freeze during the update and so a corrupted update?
im very sorry, for my newbish post, i also not sure about what gui i had, so i said lightdm because i remembered it was part of the gui but i might be wrong.

sorry for the super confused response, i mean how to restore the gui… i forgot the name of the default gui provided with lubuntu… ><’

If you were on Ubuntu 18.04 LTS (via a Lubuntu 18.04 LTS install), then yes, your Ubuntu 18.04 base system will offer an upgrade (not Lubuntu, but the Ubuntu base), which will upgrade your system - alas it breaks the Lubuntu/GUI which is why it was not supported by Lubuntu.

You should be able to login to a text terminal and explore your system, as the Ubuntu base system should correctly upgrade. If you read the release notes, you were warned of this.

You can explore /var/log/dist-upgrade for logs of upgrades performed which will confirm.

Yes you can fix an upgraded LXDE to LXQt system (the system I’m replying to you on was such an upgrade; done back in late-2018), however it took me near 3 weeks to get my system to what I consider stable… I’ve upgraded many LXDE/Lubuntu systems to modern LXQt a number of times, some were easy, others were problematic - it’s no fun (and you still risk menu items that go nowhere etc as you’re no longer running LXDE but menu items were created for options back when you were using LXDE - ie. the result isn’t as polished).

Either way Lubuntu does not support LXDE upgrades to LXQt which is why we tell you to re-install your system. Ubuntu support options can be found here.

the log is super messy

Start-Date: 2021-08-23 23:13:47
Requested-By: wiileewaller (1000)
Install: gcc-10-base:amd64 (10.3.0-1ubuntu1~20.04, automatic), libcrypt1:amd64 (1:4.4.10-10ubuntu4, automatic), libcrypt-dev:amd64 (1:4.4.10-10ubuntu4, automatic), libgcc-s1:amd64 (10.3.0-1ubuntu1~20.04, automatic)
Upgrade: libc6-dev:amd64 (2.27-3ubuntu1.4, 2.31-0ubuntu9.2), libc6:amd64 (2.27-3ubuntu1.4, 2.31-0ubuntu9.2), locales:amd64 (2.27-3ubuntu1.4, 2.31-0ubuntu9.2), libc-bin:amd64 (2.27-3ubuntu1.4, 2.31-0ubuntu9.2), libc-dev-bin:amd64 (2.27-3ubuntu1.4, 2.31-0ubuntu9.2), libidn2-0:amd64 (2.0.4-1.1ubuntu0.2, 2.2.0-2)

found that but not sure it helps a lot

That is found in most release notes of the various Lubuntu releases using the LXQt desktop (18.10 & higher) though I quoted from 20.04

Myself, I like the upgrade via re-install that Ubuntu has always offered with its installers. ie. use “Manual Partitioning” (as found in calamares in Lubuntu 18.10 & up) or “Something else” (as found in ubiquity used by main Ubuntu and the majority of Ubuntu flavors), selecting existing partitions and ensure you don’t format any.

This causes the following to occur

  • your installed packages are noted
  • system directories are erased (ie. server application configs may be lost, but this doesn’t impact desktop apps)
  • new system is installed
  • your additional packages noted earlier are attempted to be re-installed, IF available in the new release in Ubuntu repositories.
  • you are asked to reboot (with no user file touched unless you selected to format; ie. clean install)

I love this install option as it’s faster than the release-upgrade in most cases; and lets you re-install the same release, or skip a release (if you want to). It’s not perfect, it doesn’t handle 3rd party packages well, nor where packages are removed from repositories (eg. in 2019 Qt4 libs not ported to Qt5 were removed; as were python2 as both were EOL so won’t exist in 20.04, but did so in 18.04). You may get an error message stating some packages could not be re-installed; accept that (it’s not a bug, it just happens) & take note of what they are. In my experience they are of no significance or easily fixed yourself.

The fresh install is cleaner as leaves no dangling threads, (ie. some user configs in your older box may no longer make sense, as they were intended for LXDE and not LXQt). On a fresh install the format would have erased them, but this dirty install (no format) means they remain where they exist in $HOME or your user directory (ie. all your configs will remain).

Despite this not being the cleanest approach, it’s my backup should an upgrade fail. OR I run out of time to attempt to fix the issues & need the system operational again in a hurry. It’s not the fresh install supported by Lubuntu, but it’s what I’d use for my own boxes (I QA-test for it regularly; we have a QA-testcase for it; install with an existing partition though it’s using a previous LXQt desktop)

 guiverc@d960-ubu2:/var/log/dist-upgrade$   rmadison libc6-dev
 libc6-dev | 2.15-0ubuntu10    | precise          | amd64, armel, armhf, i386, powerpc
 libc6-dev | 2.15-0ubuntu10.23 | precise-security | amd64, armel, armhf, i386, powerpc
 libc6-dev | 2.15-0ubuntu10.23 | precise-updates  | amd64, armel, armhf, i386, powerpc
 libc6-dev | 2.19-0ubuntu6     | trusty           | amd64, arm64, armhf, i386, powerpc, ppc64el
 libc6-dev | 2.19-0ubuntu6.15  | trusty-security  | amd64, arm64, armhf, i386, powerpc, ppc64el
 libc6-dev | 2.19-0ubuntu6.15  | trusty-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el
 libc6-dev | 2.23-0ubuntu3     | xenial           | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libc6-dev | 2.23-0ubuntu11.3  | xenial-security  | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libc6-dev | 2.23-0ubuntu11.3  | xenial-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libc6-dev | 2.27-3ubuntu1     | bionic           | amd64, arm64, armhf, i386, ppc64el, s390x
 libc6-dev | 2.27-3ubuntu1.2   | bionic-security  | amd64, arm64, armhf, i386, ppc64el, s390x
 libc6-dev | 2.27-3ubuntu1.4   | bionic-updates   | amd64, arm64, armhf, i386, ppc64el, s390x
 libc6-dev | 2.31-0ubuntu9     | focal            | amd64, arm64, armhf, i386, ppc64el, riscv64, s390x
 libc6-dev | 2.31-0ubuntu9.2   | focal-updates    | amd64, arm64, armhf, i386, ppc64el, riscv64, s390x
 libc6-dev | 2.33-0ubuntu5     | hirsute          | amd64, arm64, armhf, i386, ppc64el, riscv64, s390x
 libc6-dev | 2.33-0ubuntu9     | impish           | amd64, arm64, armhf, i386, ppc64el, riscv64, s390x
 libc6-dev | 2.34-0ubuntu1     | impish-proposed  | amd64, arm64, armhf, i386, ppc64el, riscv64, s390x

You were on Lubuntu 18.04 LTS (old package matches bionic-updates & new package matches focal-updates) and thus performed the unsupported by Lubuntu upgrade, moving from 18.04 to 20.04. You can take what I offered you, or try using Ubuntu support (Lubuntu doesn’t support your upgrade path as all our release notes warned).

omg worst case so… u_u

dont know why the os gui suggest me to break my pc…

Your Ubuntu 18.04 base system offers the upgrade, which is why Lubuntu warned users not to take it. The system warns you to read release notes before upgrade (but yes that is easily overlooked as its the small print we’re almost conditioned to ignore) but you as operator/user should always read the release notes before you jump and accept a yes.

Your Ubuntu base system (ie. Ubuntu Server or terminal based system) should be good. It’s only the GUI that was warned would break.

ok i understand… now, thnks for helping me but im not sure i understand what you meant is there a step to step recover solution tutorial anywhere for the " upgrade via re-install "

I guess i have to reinstall lubuntu… … is it possible to recover the fstab? or it not recommended to copy past this over a reinstallation?

/etc/ is a system directory so anything inside that directory is wiped by the install I mentioned.

I often take a copy of /etc/fstab & /etc/hosts as I usually modify those on my systems (for me a copy is usually scp to another box)

I don’t usually copy them back post-install; but just diff them and add anything I feel I need on the new installed files.

Other places I look include /usr/local/bin/ - but that’s because I put many files in there myself. All my added themes, fonts etc I know are erased by this install (I don’t store mine in $HOME but use system directories as I don’t want them to be backed up, but I suspect most users don’t do what I do), but I find restoring them super-easy from a network drive, but again that’s just how I do things.

I’m not aware of any step-by-step instructions anywhere that I can point to; I’ve written about it 30+ times on askubuntu & elsewhere, but often in comments (not answers) as I love that install option offered by Ubuntu and flavors of Ubuntu (most GNU/Linux do not provide it unless /home is on a separate partition).

I’ll read back what I said & see if I need to expand/comment further (I scroll window up & read…) nope looks okay to me.

How well it goes will depend on what you’ve done to your system. You’ll have more issues where you use 3rd party packages (ie. PPA or non-Ubuntu sources), other than that I mentioned the big changes I can think of between bionic (18.04) & focal (20.04), ie. dropping of python2 due EOL & Qt4 packages that weren’t ported to Qt5.

1 Like

Examples of what I describe that may use other wording & help you better understand/feel more comfortable

etc… these were found by searching for "upgrade via re-install" site:askubuntu.com on startpage.com which offers many many more

Note the wording on the questions will vary; eg. the first Kubuntu one uses language used by Kubuntu’s use of ubiquity with it’s Qt skin; ie. the “Manual” option is called “Manual Partitioning” in calamares as used by Lubuntu.

Sorry i couldnt anwer earlier due to the limitation of messages…, so thanks for the help, i ve thinking about a fresh install of the new version 20.04 BUT without “format” during the process, if i copy paste the fstab do you think it ll keep the config, sorry to bother with this fstab file it is mainly because i have 4 hdd of many TB with many partitions and its super time consuming to re-configure everypartition…