Permissions Denied


A few weeks ago I installed lubuntu 22.04.1 on a dell studio laptop which was bought in 2008. I’m trying to access files on an external hard drive to either view them (images, docs, pdfs etc.) or play them (mp3 files) but whenever I try to opening the folder, it says “Error opening directory '/media/brian/…Permission Denied” I even though I am the only user on the computer - I installed lubuntu on it and set the whole thing up. Is there a way for me to get around this or fix this?

I have tried to go to tools > Load in Root instance and tried playing the file but the vlc player will never appear.

So if I understand correctly, when you open the file manager (PCManFM-QT) as root, you can access the files just fine but you can’t open the files?

VLC is not running as root—so likely can’t access/open the files you see if there’s a permission issue.

My guess would be to check/verify the permissions for the volume or directories/folders.

If you’re not going to use the drive and files on another PC, you can try changing the permissions via terminal and make it so that your account has permissions to at least read what’s on there. This of course assumes that the file system on the external drive is ext4 or something.

Unfortunately, you’re going to have to use terminal to figure this one out and perform remediating tasks.

Apparently you can just right-click the directory and check out the permissions that way too.


You can use this command to see what permissions are on the external drive file system:

ls -l /media

Hopefully the output of that will actually tell you something useful like what permissions the directory has (in your case, I think it’s brian you need to look at).

From there, I guess you can go different ways about it. (e.g. changing permission to let everyone read and execute to directories for brian and directories under)

I’m not sure if this drive always worked, if it was formatted on a Windows box before, etc. I also don’t know why it’s getting mounted and not letting you access it.


Thank you very much for your help. The disk was bought years ago and it was formatted for mac (unfortunately in hindsight). I don’t know how it is formatted and I don’t want to fiddle with it too much as I have years of backups on it.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.