Panel Clock Error

Hi. I have successfully installed Lubuntu on my Acer Aspire netbook.
The problem: The panel clock (24 hour) is accurate, except it shows PM when it is AM and vice-versus. I have installed NTP and it is running. The Time and Date settings are set to the correct Los Angeles time zone. The configuration is set to “Keep synchronized with internet servers.”
Help! This little error is driving me crazy!

Welcome. I’ll firstly request your release of Lubuntu (panels are different if using legacy (LXDE) or modern (LXQt))…

I’ll also provide the manual pages (assuming a modern Lubuntu release).

Hi. My Lubuntu release is LXDE.

Can I get your Lubuntu release please.

Please open a terminal and post the output of lsb_release -sd.

The output of lsb_release -sd is:
Ubuntu 18.04.3 LTS

I booted a Lubuntu 18.04(.3) LTS system, installed ntp and modified my timezone to be America/Los_Angeles. Other than my clock being yesterday & night (it’s sunny outside & day later due my timezone) everything was as it should be.

To get into format for your clock, right-click on the panel-clock and select “Digital Clock Settings”. I’ll be subsequently talking about setting the “Clock Format” which is the first field (Tooltip format is when you hover your mouse over the clock).

My preference is 24hr clock and my used format is “%a %Y-%m-%d %R:%S”, so I changed it firstly to “%I:%S” then tried a few variations. I did get it acting strangely (appeared to be 12 hours out as your describe), but then wasn’t able to re-create it so I may have been I used incorrect combinations.

I’d recommend your fix is to use “%I:%M %p” (iota, mike, papa) as your clock format to give “07:27 PM” with a leading zero, use “%l:%M %p” (lima, mike, papa) adding “:%S” if you like seconds too. Note case matters!

I’ve made a huge assumption that your issue is a bad “Clock Format” string in your digital clock settings. I’d suggest you note/copy what it is before changing, so if you make a mess of it you it, you have something to copy back to restore at least what you had.

If you’d like me to test or provide more clues or details, or my guess is wrong, please just write back. Also if I’ve just confused you.

I never remember the codes so open a terminal window & man date to view what’s available and what each code means.

Well, your suggestion worked!
You were right, it must have been an incorrect clock format setting.

Thank you so much!

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.