New install (new hardware), wifi disconnects

I have a relatively bleeding-edge laptop[1]. I was able to boot Lubuntu 19.10 “Live”. But, the wifi seems to connect/disconnect. (After 10 seconds, I get a notification in the upper-right corner of the screen: “connection lost.”).

I was able to proceed with install. But, that error remains.

I was going to gather “inxi -Fxzrs” but Lubuntu doesn’t seem to have that. (And, I have no internet to install that package.). If there’s another command I can use, I’d be happy to do that. I imagine the problem is related to chipset. When I had a different distro installed, inxi -F said:

“Device-2: Intel Wireless 7265 driver: iwlwifi”

Thanks!

[1] Acer 5 (A515-43-R19L), Ryzen 3 3200u, Radeon Vega 3; 128g SSD; 4g mem.

Seems like a great bargain. “Amazon Choice.” Expandable to 32gb mem (2x 16gb). Space for a SATA-3 drive. I plan to install linux (root, “/”) on the SSD, and /home on a SATA-3.

I always find it’s helpful to have the PCI ID among other things. Try lspci -nnk | grep -A 3 Network.

Incidentially I’m currently running a 7265 (8086:095a) with iwlwifi and it’s behaving just fine.

Have you looked at the logs?

1 Like

Thank you! It’s working now! Just to confirm again: Lubuntu 19.10 installs no problem on an Acer Aspire 5 (model: A515-43-R19L; CPU: Ryzen 3; graphics: Radeon Vega 3). Seems like a fantastic value, big seller on Amazon, and wouldn’t surprise me if people are googling it. I found a couple success reports (Mint & Archlinux) before I bought it. I’m, just trying to get into the search results in case anyone wonders if Lubuntu works. (I had to change 3 things in the BIOS. I described that in another post.).

The wifi problem: Lubuntu saved my wifi connection without the password.

I woke up in the middle of the night wondering if that happened. I’ve never seen a distro save a wifi connection that refused to connect. (I thought they remained in a loop prompting for the correct password.). But, I woke up last night thinking I should delete that saved connection. I do remember struggling not to touch the touchpad while I typed the wifi password. (I never thought about that again when it saved the connection, and just clicking on it caused it to attempt reconnect. I thought it was connecting and disconnecting. Apparently I was clumsy when creating that connection. Strange that it happened twice: during LiveCD before install, and after install.).

I saved your suggested info-command in case I have trouble in the future.

I’ll go back and edit my other post where I mentioned I had a wifi problem.

I’m going to reinstall Lubuntu 19.10; to start fresh and follow the same steps I do when comparing mem usage. I’ll come back and post the results of that after I install a few distros.

One odd thing when dealing with my bad-password. I first right-clicked on the network connection in the tray to edit the saved connection. The editing window was a curses(?) text-based display. That didn’t seem to work right. As I tabbed down to “[ ] show password,” the place to “x” that wasn’t editable. I was placed into a text-entry field that was on top of the “w” of “password”. I thought that’s where I was supposed to put the “x”. But, apparently that’s the password field and “x” overwrites whatever value is there. (The window shows the password field one line higher. S, I thought I was supposed to put the “x” on the scrambled line below, then go above to edit the password field.).

Anyway, I went to Menu->Preferences->Advanced Network Connections. I deleted the saved wifi connection there. Then went back to the task bar’s network icon. Left-clicked, chose my wifi again, entered the password. That worked. (I could have created the connection from that from the “advanced” gui. But, I wanted to do it from the taskbar icon since I imagine most people use that.).

It all worked. But, it seems like that taskbar icon has some issues.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.