'maximize' doesn't actually maximize

I use two monitors: my laptop and an external, larger monitor. Laptop is my primary one. I have them aligned on top:

image

The problem is that when I maximize windows in my external monitor, the size of the windows seem to only reach the height of the primary monitor instead of using up all the available space in the large monitor. This is: the window top goes to the top of the monitor, but the window bottom goes to the bottom of the primary monitor instead of the current monitor.

I tried with and without ‘keep monitors attached’ option.
In the large monitor, the panel shows fine, the mouse can travel all around, and if I change the size of the windows manually I can make it fit the monitor. But for some reason ‘maximize’ order does not actually maximize the window.

How to fix this?

Your description reminds me of https://bugs.launchpad.net/ubuntu/+source/lxqt-session/+bug/1809201 .

If you have a look at the bug report, and believe it matches your condition (and only if it matches your situation), you can click “Affects me to”, and please leave a comment (on bug report) with details.

I’m interested in how ‘fresh’ is your install (how long ago did you install?) as in time the problem seems to vanish (upstream at one stage felt it was an uninitialized value that once a change puts a value there, the problem is solved - thus my question).

If it’s what I’m thinking about; I don’t have answers, except I work around the issue, but you’ll likely discover in time the issue just disappears anyway (ie. it works exactly as you wish all of a sudden & from then on).

By changing the ‘primary’ monitor (or value in Monitor.Settings, exit etc) a few times you maybe able to make that ‘in time it goes away’ occur faster but I was unable to find a pattern that worked reliably for me on new installs. The issue isn’t I’m talking about isn’t limited to just Lubuntu either (ie. it’s an LXQt issue)

guiverc thanks for your help.
It turns out it is related to my other post
So, when I have two monitors ‘touching’ they seem to be sharing a row of pixels:
image

So my interpretation is that, when to monitors are so close together in the Monitor Settings, Lubuntu seems to consider both like forming part of giant screen in this sense: a maximized window is only as tall as the primary screen.

Now when I separate them a bit like this:
image

It works as expected: each windows maximizes up to its own screen size.

1 Like