Lubuntu switches entirely from Compton to Picom in Lubuntu 23.04

Lubuntu has featured the Compton X compositor for a while. Recently, in Lubuntu 23.04, the Lubuntu Development team has removed Compton entirely from Lubuntu, and switched entirely to the newer Picom compositor. The Picom compositor has been installed for a while, along with Compton, but both were disabled by default. Compton has now been removed from the Lubuntu seed, meaning it won’t be present in new daily ISOs of Lubuntu 23.04, and will probably not be present in the final release of Lubuntu 23.04. Picom has also been enabled by default.

Those who use Lubuntu 23.04 Lunar should probably purge the compton-conf package from their systems, and then run an autopurge (assuming you’ve not made any changes to your system that would make an autopurge cause damage to the rest of the system).

Note that this does not affect any users of Lubuntu 22.10 or earlier - you only need to do anything if you are running the Lubuntu 23.04 development release.


Note to self or others, but we’ll have to check release-upgrades have the compton-conf package removed as expected.

I don’t see any hurry on this though; it can always be covered with a note in the release notes of 23.04.


Ran 2 upgrade tests Lubuntu Kinetic to Lubuntu Lunar and can confirm the compton-conf package was removed as expected in both cases.

1 Like

Does this mean LXQt Configuration Center > Window Effects
will be gone for good ?

It will probably be gone in Lunar, I believe. It might not be gone forever, though. While we haven’t committed to the idea, we were thinking about the possibility of rewriting compton-conf to work with Picom and then shipping that sometime in the future. We have a lot on our plate, so this probably won’t happen this release, and we can’t guarantee it will happen any time soon, if at all, but it is an idea.


Glad to see this move because Compton is no longer being developed. I have used both over the years off and on. I switched to Picom long ago due to smoother desktop feel on older hardware. I would not expect the change to be noticed by many users with modern hardware.

I recall running the autoremove for the compton-conf package with my Lunar Lobster development machine.


I installed 23.04 today and Picom always crashes at startup (popup in DE says something like ‘too many crashes’. DE works fine, only the default font is wrong). I just checked if compton-conf is still installed and it is. Any advice?

What ISO did you install 23.04 from? You shouldn’t have compton-conf installed anymore, I don’t believe. (I just confirmed that nothing named “compton” is present on the official Lubuntu 23.04 release ISO.)

I did a normal dist-upgrade from 22.10 via terminal. The little crash report popup says (if I translate it back to English): “Picom (X11 composition manager) crashed too often. Its automatic restart is deactivated until next login.” I don’t recall anything strange during installation. Thanks…

Ah, I see.

Can you open a QTerminal window and run picom in it? This will try to run picom, it will probably crash, and when it does it will hopefully share some info about why. Paste that info here.

1 Like

picom in terminal says:

[ 21.04.2023 18:11:02.919 open_config_file_at WARN ] This compositor has been renamed to “picom”, the old config file paths is deprecated. Please replace the "compton"s in the path with “picom”
[ 21.04.2023 18:11:02.919 parse_config_libconfig WARN ] Option menu-opacity is deprecated, and will be removed.Please use the wintype option opacity of popup_menuand dropdown_menu instead.
[ 21.04.2023 18:11:02.919 parse_config_libconfig WARN ] The refresh-rate option has been deprecated. Please remove it from your configuration file. If you encounter any problems without this feature, please feel free to open a bug report
[ 21.04.2023 18:11:02.919 parse_config_libconfig ERROR ] vsync option will take a boolean from now on. “none” in your configuration should be changed to “false”
[ 21.04.2023 18:11:02.919 main FATAL ERROR ] Failed to create new session.

And I removed the packages compton and compton-conf. But the pop-up, the crash and the terminal message when typing picom remain the same.

I solved the problem by following:

So I moved my old compton.conf to a new folder named picom in my .config, renamed the file to conf and added some info according to the samples the link provides. No crash anymore at startup and no errors in terminal.


Hmm, good to know. I wonder if you had a custom compton config before this? The errors indicated that you had bad info in your compton configuration file.

1 Like

I still have a compton.conf backup. If I copy its content into the picom config file, picom still starts and runs just fine…

Huh. I guess having it still being considered “compton” configuration got it mixed up somehow? Weird. Anyway, glad you got it all worked out :+1: I’ll try and remember this for in the event anyone else runs into this.