Lubuntu apt problem

Hi, I have a problem with my laptop and lubuntu. It’s imposiible to upgrade/update/install/…
I’ve tried to populate /etc/apt/sources.list with this data but it doesn’t work.
repogen.simplylinux.ch/generate.php
(It doesn’t matter the country, Spain and UK,for instance, fail)

Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful

Could you help me?
Thanks

It is out of support so it does not let you update, you should install a higher version. You have 18.04 (with LXDE desktop) with 3 years of support (April 2021) or 19.04 (with LXQt desktop) with nine months of support since April of this year.

I see that you are from Spain, you have a telegram or irc channel for support if you need it.

Check it out here: https://lubuntu.me/links/

Lubuntu 17.10 (in fact all Ubuntu 17.10 and flavors) reached EOL on July 19. 2018. (https://fridge.ubuntu.com/2018/07/19/ubuntu-17-10-artful-aardvark-end-of-life-reached-on-july-19-2018/)

Released in 2017-October (thus 17.10) the release had 9 months of support life, and should have been release-upgraded to Lubuntu 18.04 LTS prior to EOL (or just afterwards). After the release becomes EOL, archives move from http://archive.ubuntu.com to http://old-releases.ubuntu.com though no date is specified except it occurs after EOL is reached.

If you needed a longer life than 9 months, you should install LTS or long-term-support releases, as these are supported for 3 years for Lubuntu (and Ubuntu flavors). Lubuntu 18.04 LTS is the most recent LTS release.

If you want the latest LXQt desktop, a clean install of Lubuntu 19.04 is an option, or you can modify your system to let it update to 18.04 LTS (this should help https://askubuntu.com/questions/91815/how-to-install-software-or-upgrade-from-an-old-unsupported-release with a sed script that will do what I mentioned above, but note there are no country mirrors for EOL releases)

Also maybe helpful - https://help.ubuntu.com/community/EOLUpgrades

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.