Lubuntu 24 big problem with amd hd 7770 saphire

Hi guys, I have a big problem with Lubuntu 24 and the HD 7770 Saphire video card. Basically, after the upgrade 23 to 24 I no longer see anything. The PC turns on regularly but doesn’t display. I tried to log in remotely to the PC via SSH and it works, so it’s OK. just a problem with the video card, I tried to replace it with an msi rx2600xt and everything works perfectly, then I installed the AMD drivers from the amd site but nothing continues to appear with 7770 vga card, does anyone have any ideas about this ? thanks, i try also to give a drive specific amd fglrx but retur me this:

AMD Proprietary Driver Installer/Packager

error: Detected X Server version ‘XServer 1.21.1.11_64a’ is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib:XServer 1.21.1.11_64a:none:6.8.0-31-generic:)
Installation will not proceed.

I’d probably file a bug against the kernel. This should not be a Lubuntu-specific issue.

2 Likes

What driver were you using on Lubuntu 23 (before the upgrade)? Did you create a custom config file for your card or xorg.conf?

I have an old Radeon HD 5830 and it is also not supported anymore by newer XServer so downloading the driver from AMD website and trying to install the fglrx driver will NOT work. Best bet is to use the radeon driver.

1 Like