Lubuntu 21.04 Error When Installing

Hello Lubuntu community, as the title states I have been having troubles installing Lubuntu 21.04 on my Lenovo ideapad 320-15IAP. I have thoroughly followed the step-by-step guide to install Lubuntu. I am able to boot into Lubuntu after flashing the ISO to my USB, but when I run through the installation setup (where it says Install Lununtu 21.04), it proceeds to install, installing the bootloader and that is where the error pops up. I thought it may have been the USB, so I tried another, and the problem persisted. I have tried the Erase disk, Manual partitioning, and Replace a partition options, but I get the same error for all three of the options.

Below is a picture of the error I am getting.

Lenovo ideapad 320-15IAP Specs:
CPU: Intel Celeron N3350 / 1.1 GHz
RAM: 4 GB DDR3L SDRAM
Display: 1366 × 768
Graphics: Intel HD Graphics 500
Sound: Stereo speakers, microphone
Wireless Network Card: RTL8821AE

Hi,

Did you create an EFI system partition during the manual partitioning?

If you didn’t, It could be the problem, but perhaps I am wrong.

Greetings.

1 Like

Yes, the /boot/efi? I had given /boot/efi 500 MiB, set the filesystem to fat32, and set the boot flag. Still got the same error.

Let’s check some basic things first:

  • Is the hash sum of the downloaded ISO file correct?
  • Do you have the newest firmware version (check on vendor support site)

Please check also the firmware settings. There might be some setting to prevent changing the EFI variables. For example “Boot Order Lock”.

If it is still not working, please show the complete output of

sudo parted --list
sudo efibootmgr --verbose

With the informations, we can then try to install the bootloader manually.

1 Like

I checked the hash sum and it is correct. I’m not totally sure what you mean by firmware? The BIOS settings version? I couldn’t find Boot Order Lock but here are the BIOS settings in pictures below.

Here is the output of the commands you told me to run.

lubuntu@lubuntu:~$ sudo parted --list
Model: ATA ST1000LM035-1RK1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      2097kB  317MB   315MB   fat32              boot, esp
 2      317MB   1000GB  1000GB  ext4


Model: Lexar USB Flash Drive (scsi)
Disk /dev/sdb: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  32.0GB  32.0GB  primary  fat32        boot, lba


Model: Unknown (unknown)
Disk /dev/zram1: 983MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End    Size   File system     Flags
 1      0.00B  983MB  983MB  linux-swap(v1)


Model: Unknown (unknown)
Disk /dev/zram0: 983MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags: 

Number  Start  End    Size   File system     Flags
 1      0.00B  983MB  983MB  linux-swap(v1)

And the second command (which I had to install efibootmgr beforehand)

lubuntu@lubuntu:~$ sudo efibootmgr --verbose
Skipping unreadable variable "Boot0000": Interrupted system call
Skipping unreadable variable "Boot0001": Interrupted system call
Skipping unreadable variable "Boot0006": Interrupted system call
Skipping unreadable variable "Boot0007": Interrupted system call
Skipping unreadable variable "Boot0008": Interrupted system call
Skipping unreadable variable "Boot0009": Interrupted system call
Skipping unreadable variable "Boot2001": Interrupted system call
Skipping unreadable variable "Boot2002": Interrupted system call
Skipping unreadable variable "Boot2003": Interrupted system call
show_order(): Interrupted system call

Thanks, Bill!

Technically you do not have a BIOS, but a UEFI firmware. Unfortunately, the firmware is still called BIOS, (even on the Lenovo support site). The latest firmware is 5RCN36WW from september 2018. And unfortunately it is only available as an *.exe file (Windows).

In the picture, I do not see any setting, that could cause your problem. Maybe it is in the “Security” tab.

Because the firmware blocks not only write access, but also read access, I strongly suggest you the following:

Change the firmware setting “Boot Mode” from “[UEFI]” to “[Legacy Support]”.

When you start the installer, you should see on the “Partitions” screen on the upper left side the word “BIOS” instead of “EFI”. If you see “BIOS”, you are in the correct boot mode and can continue with the installation. If not, you will very likely run into the same problem again.

Because you use GPT as partition table, you need a “bios_grub” partition. I am not sure, if the installer creates it automatically. If the partition is not created automatically, you will either need to do it manually or (easier) change the partition table to MBR.

1 Like

I got past the installing bootloader, but now I get this error.

I fixed this problem and successfully installed Lubuntu. I had cleared all the partitions of the hard drive after restarting, then installed again and got no errors. That’s what fixed the calamares error for me. Thanks @apt-ghetto and @ubun-ie for the help as it is now working.

2 Likes

Hi not sure if this is the right place, maybe I should start a new topic, but I am having a similar error. I have an older system that is booting with legacy bios (not EFI). I’m dual booting windows 10, and the install process goes perfectly up until this near-last stage which fails with the same pop-up window as BillJoe1979 but a different error message–
"Boost.Python error in job “bootloader”.

Command ‘grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=ubuntu --force’ returned non-zero exit status 1.

Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn’t look like an EFI partition.
"
which is correct, it isn’t an EFI partition. I’ve been burning google down but I haven’t found a way to ask Lubuntu to install on a legacy bios partition. Would appreciate any help!