Lubuntu 20.04 does not setup grub

Hi,
I have W10 on SDA1.
Until lately I had Lubuntu 18.04 on SDA6
Lubuntu 18.04 installed and setup grub as well.
All perfect

Now I have installed Lubuntu 20.04 on SDA6
And then nothing, no grub
When I restart the system jumps to W10
No choice for Lubuntu 20.04

I must have missed something.
Can you take me by the hand to create a dual boot system?

Please boot the installation medium, open a terminal and post the output here:

sudo parted --list
sudo efibootmgr -v # sudo apt update && sudo apt install efibootmgr if it is missing
1 Like
Model: ATA WDC WD40EFRX-68N (scsi)

Disk /dev/sda: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 336GB 336GB ntfs msftdata
2 336GB 2669GB 2333GB ntfs msftdata
3 2669GB 3824GB 1155GB ntfs msftdata
4 3824GB 3824GB 1049kB bios_grub
6 3824GB 3954GB 130GB ext4
7 3954GB 3996GB 41.9GB ext4 Linux-test
5 3996GB 4001GB 4403MB linux-swap(v1) swap

Model: ATA CT240BX200SSD1 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 525MB 524MB primary ntfs boot
2 525MB 240GB 239GB primary ntfs
3 240GB 240GB 553MB primary ntfs msftres

Model: USB DISK 3.0 (scsi)
Disk /dev/sdc: 31.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 31.7GB 31.7GB primary fat32 boot, lba

Model: Unknown (unknown)
Disk /dev/zram1: 2755MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

lubuntu@lubuntu:~$ sudo efibootmgr -v

EFI variables are not supported on this system.

Please enter the UEFI/BIOS setup and check, that your 4 TB disk is in the boot order before your 240 GB disk.

On 18.04 it was all automagic.
I have a 240G SSD for boot with W10
Should I change flags using GParted?

I’m sorry but on this terrain (bootloaders) I’m quite a noob.

No, don’t use GParted.

You have to enter your UEFI/BIOS setup. Normally, the firmware is looking for a bootloader and boots the first one.

I guess, you have the 240 GB disk at the first position to look for a bootloader and therefore it boots Windows. But if you change the boot priority of your disks, then it will look for the bootloader on the 4 TB disk, where the Lubuntu bootloader is (probably).

Hi,
It’s OK now.
When installing there are 3 options,

  • alongside
  • choose a partition
  • format a partition

This time I chose the 2nd instead of the 3rd and got the right options afterwards.
All went smooth, bootloader loaded on /dev/sdb (the SSD on which W10 resides)

Thanks @apt-ghetto for advising.

1 Like

Well, the next time, Win 10 does update the bootloader, it overwrites Grub and you have to reinstall Grub again.

In my opinion, you should install Grub onto the other disk and change the boot priority in your firmware settings.

2 Likes