Lubuntu 19.04 booting from USB stick

Hello everyone, I have downloaded the 19.04 version, made bootable USB stick using the Rufus utility, installed the system on my laptop, all went smoothly. However, when I remove my USB stick and restart the computer, the system is going to boot again from the USB, not from the HD, even though, the system in on the harddrive installed. Any idea where is the issue?

I’m not completely sure I understand what you are describing, but I’d guess it’s either

(a) BIOS/UEFI setup setting that is telling the system to boot USB drive; and the fix is changing this setting on your machine so it boots your hdd/sdd first

(b) you didn’t install the bootloader, or installed it on the wrong device (such as your maybe your install thumb-drive?). What I mean here is shown at the bottom of this install picture from the Lubuntu manual

though if you chose other options during install it may have appeared elsewhere on the screen.


If it’s (b) the steps I’d use to fix can be found at Grub2/Installing - Community Help Wiki which need to be adapted to your machine, so a re-install may be faster/easier if it looks complex.

1 Like

Hello, thanks for your comment. Sure, I checked the BIOS and there is HDD as a default booting device. I followed the instructions, selected “Erase Disk” as I am going to use Lubuntu as only OS. Concerning the bootloader, I did not make anything with that option, I kept it without changing as it was set by installing procedure. When I check my HDD in Lubuntu, the system files are there.

Is your device BIOS (old) or UEFI (newer) if you know? or what is your device? There is a good chance I won’t be familiar with it, but others may know it (or devices like it) that can help even if I can’t.

(I’m thinking you are using UEFI which means the boot loader option may not have been changeable, and it’s a BIOS/UEFI setting that needs a change and once done it’ll just work on re-install; I had trouble with this on a sony vaio)

I have not my laptop at my hand to check it but it is an HP, 5 years old.

Please start the live-system, open a terminal and post the answers of

sudo parted --list
sudo efibootmgr -v

And check also, that you have the latest UEFI/(or BIOS) installed/flashed. Years ago, HP had an UEFI implementation, where the bootloader path was hardcoded to the Windows bootloader (UEFI booting mode).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.