Lubuntu 18.04, problems loging in with Teamviewer 15

Hi, my first post.

I have a Lubuntu 18.04 machine at a remote site, I have installed Teamviewer 15 (free) and it is working well however, when the screen is locked or when the log-in screen is up, I cannot access remotely via Teamviewer.

Remote machine is showing as available in the list of ‘my computers’ on Teamviewer however I cannot connect until I get someone to physically log-in at the other end. Any ideas?

I have searched and seen mentions of Wayland/LXDE desktop issues.

Can anybody help?

Hi, very same problem here with Lubuntu 20.04.
I read there r ways around this with gdm and lightdm, but not with SDDM.
I tried to switch to lightDM on Lubuntu but couldnt login anylonger via GUI.
I may have to change distro due to this problem.

1 Like

HI

Yes I have also tried it on a 20.04 machine and have the same issue. No good for me as I need to have remote access and also lock the screen to stop unauthorised access. As soon as I lock the screen I lose Teamviewer connection.

Since TeamViewer is a proprietary software application, I wouldn’t generally expect the free software community to be of much help to you. I would contact TeamViewer about these issues.

Also, I would add that I use a remote desktop solution in Lubuntu on a daily basis as part of my employment and have for years. In all the solutions that I have tried, none are better than NoMachine. It, too, is proprietary, and that is not something I love about it, but generally it works so well, I’m not very practically concerned with that fact.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.