Lubuntu 18.04.5 32 bits sound pop, stutering and increasing and decreasing volume

Machine Pentium M 2 GHZ 2 GB RAM Lubuntu 18.04.5
The sound is displayed in windows being Sigmatel and in Linux ICH6 AC’97.
The sound works with problems in any software from media player to web browse.
The sound pops with noise, stutering and increasing and decreasing volume mainly in voices.
Playing youtube videos have noise and pops and when has voice the increasing and decreasing volume extremely. Play fine with few pops if the video not has voices (tested with Pink Panther cartoons).
When happen the problem the CPU usage is below of 75 %.
Not problems in sound speaker because using windows in same machine not has any issues.
Thanks for reply.

More information needed. Try sudo lshw -C multimedia and give us the results.

1 Like
       descrição: Multimedia audio controller
       produto: 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
       fabricante: Intel Corporation
       ID físico: 1e.2
       informações do barramento: pci@0000:00:1e.2
       versão: 03
       largura: 32 bits
       clock: 33MHz
       capacidades: pm bus_master cap_list
       configuração: driver=snd_intel8x0 latency=0
       recursos: irq:16 porta de E/S:ed00(tamanho=256) porta de E/S:ec40(tamanho=64) memória:dffffe00-dfffffff memória:dffffd00-dffffdff

Aw hell, that doesn’t have the PCI ID. Can you run lspci -nnk and pull out just the lines related to that card?

00:1e.2 Multimedia audio controller [0401]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller [8086:266e] (rev 03)
	Subsystem: Dell 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller [1028:0189]
	Kernel driver in use: snd_intel8x0
	Kernel modules: snd_intel8x0

From what I have discovered, this driver provides power-saving capabilities which have been shown to cause audio problems in other drivers. Problem is that there doesn’t seem to be a matching parameter with your driver:

$ modinfo -p snd-intel8x0
index:Index value for Intel i8x0 soundcard. (int)                                                                    
id:ID string for Intel i8x0 soundcard. (charp)
ac97_clock:AC'97 codec clock (0 = whitelist + auto-detect, 1 = force autodetect). (int)
ac97_quirk:AC'97 workaround for strange hardware. (charp)
buggy_semaphore:Enable workaround for hardwares with problematic codec semaphores. (bool)
buggy_irq:Enable workaround for buggy interrupts on some motherboards. (bint)
xbox:Set to 1 for Xbox, if you have problems with the AC'97 codec detection. (bool)
spdif_aclink:S/PDIF over AC-link. (int)
inside_vm:KVM/Parallels optimization. (bint)
enable: (bool)
joystick: (int)

You might try the second solution in that answer since it’s a little more general. Otherwise, perhaps try flipping some of the options and see what happens (as per the first answer).

I should add: your problem is unrelated to Lubuntu specifically. More generally, it’s a problem that all Ubuntu flavors (including the canonical Ubuntu Desktop) and is likely to affect Debian and all derivatives. So this isn’t your only resource for help. You may want to spread out a bit more.


Oh yes not is related with Lubuntu, but Ubuntu forums for some questions not are exaclty good for post. I try here and
I had undestand about being problem in Ubuntu, but not had another choice to avoid post here.
I will try the options in each link.
Thanks very much. Have an nice day

Excuse me for long time to reply.
I have tested with configuration in links from your reply and now the sound is better.
Need more test.
a big thank you !

1 Like

Which specific solution did the trick for you? Please share for others and mark it as the solution. Thanks!

Hello my friend.
I will reinstall the wonderful Lubuntu and post the results here.

load-module module-suspend-on-idle change to
#load-module module-suspend-on-idle

Now the sound is much better.
Several weeks testing and not more problems with sound.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.