Lubuntu 18.04.5 32 bits how disable spectre and meltdown?

How in Lubuntu 18.04.5 32 bits disable the kernel securities spectre and meltdown ?
Thanks for reply.

You don’t need to worry about intel microcode, intel dropped support for the i386 processors (and a number of older amd64 ones too), so no fixes were ever produced.

Upgraded microcode packages may exist on your system, but an i386 isn’t capable of running the fixes, so they won’t be loaded (all microcode is packaged together and your cpu loads the portions that apply to it).

It doesn’t really apply, but I can’t find anything suitable for Ubuntu, and don’t recall where I read what my reply is based on

See here.

Ubuntu kernels have been rebuilt using retpolines on i386


No fix is currently available for Meltdown on 32-bit x86; moving to a 64-bit kernel is the currently recommended mitigation.

Intel was originally going to provide fixes for many older processors but then changed their mind.

Finally, there are kernel workarounds but ultimately this problem is not a kernel issue, but a processor one.

Here the CPU is Pentium M 2 GHZ
grep . /sys/devices/system/cpu/vulnerabilities/*
display some security are enabled
noibrs noibpb nopti nospectre_v2 nospectre_v1 l1tf=off nospec_store_bypass_disable no_stf_barrier mds=off mitigations=off
display some securities are disabled, but l1tf continue enabled.
How diasble l1tf ?
Look how the system is more fast for some types of tasks.
Need more test.

Here’s the docs.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.