Intel Wireless 7265 does not connect to the WIFI repeater/extender

Hi, it seems to be a weird problem with this release. My Intel Wireless 7265 does not connect to the WIFI repeater/extender. It does connect to the main router and other wifi. Even my phone hotspot. I tried the live USB and with Lubunto 19 works but not with 20. So it is a problem in the latest version. One person in Reddit also found the same issue. I tried to re install the network manager and few other things but none work.

*-network
description: Wireless interface
product: Wireless 7265
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
version: 61
serial: 4c:34:88:bf:db:78
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.4.0-26-generic firmware=29.1654887522.0 ip=192.168.1.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:145 memory:a1100000-a1101fff

Do you have any suggestions?

anyone has any tips? This is what I tried so far:

  • Different kernels
  • re install network manager
  • update firmware

The only solution I found is reverting back to the previous version of Lubuntu which is not something I want to do. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Oops, how did I miss this?

Could you provide the PCI ID? lspci -nnk should show it, among other things.