HP Laser 107w does not work

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy

I have an USB-connection with my HP Laser 107w printer, and installed the driver from the HP support page uld-hp_V1.00.39.12_00.15.tar.gz. I could install the ppd, HP_Laser_10x_Series.ppd, which is in that package, no indications that there are errors.

I tried to install both via the CUPS-website and via the GUI (Preferences → Printers), and the installation went fine. But when trying to print, the print job shows following line:

job-printer-state-message: The printer is unreachable at the time.

Nothing happens. The printer status: processing/pending.

Who knows how to solve this problem?

Printers and Linux used to be a real pain, since the emerge of Linux, until quite recently. Nowadays mainstream devices are supported well.

From a distance it is very difficult to evaluate what your problem is exactly. I have the same printer like you have, or at least a variant from the same series. I can’t remember going through all that effort of downloading software etc. That used to be the case in the past, and could be notorious difficult.

Since you mentioned CUPS and ppd, seems you have at least some background knowledge, experience and technical interest. I can only give you one advice: use VirtualBox.

If your system has at least 2GB of memory, you can install Lubuntu 22.04.2 again (on your system) as a Virtual Machine (VM). My choice would be to install Oracle VirtualBox for creating and running VMs.

It is user friendly and not too demanding on your system or your experience. In fact it can be quite an experience and fun to work with. It might broaden your horizon on all the Linux OSes out there, once you get the hang of it. But first…solve your printer problem :slight_smile:

You’ll have to create a new Lubuntu 22.04.2 system from an ISO, go through the usual install process…and you will have a fresh system at your disposal, inside your laptop or PC, unhampered. Ready to replay what you’ve been experiencing with your printer on your main system so far. Or do other things to get the printer running.

Before you try something you can and should make a snapshot of the fresh baseline of the VM. If needed, you can go back to that quickly. Without the lengthy process of reinstalling the VM from the ISO.

The trick which publishes the printer to the VM (as if you plugged in the USB cable) is to forward that USB connection from the host system to the VM (via the Devices menu of the VM). After that the VM “sees” the printer.

After you’ve found out how to install the printer properly (inside the VM), it might help you to do the same on the host system (your hardware).

Perhaps you 'll need to install the VirtualBox Extension Pack (on your host system) and the Guest Additions (on the VM).

If you need any help with VirtualBox, please let us know.

1 Like

I’ve being digging a bit further in my memory. Before my current printer I had the identical printer like you have, but made by Samsung (bought in 2014, model M2022). It is the almost exactly the same printer as you have, but not wireless. Samsung sold its printer division to HP, and the model remained, rebranded with a different model number.

Back then (2014) it was a bit cumbersome and laborious to get the M2022 working with Lubuntu 14.04 (“Look Maaah…my first Lubuntu”). Don’t remember the details, but it worked for me, finally.

After almost a decade of service I’ve replaced the printer with a HP model M15w (mind you, the only reason for changing it was that “w”-ireless capability).

Anyway, it is a wild guess, but considering HP’s reputation, I believe your 107w should be supported by Debian/Ubuntu/Lubuntu without any intervention from your side.

Hi Fritz,

Thank you so much for your great contributions! The suggestion of creating a VM withing Lubuntu itself is awesome: I never had thought of that!

The idea of trying the original Samsung M2022 is also a good suggestion!

But I considered, having more than one computer: let’s run a live session on that other computer, and let’s see if my printer is recognized: it instantly was! And guess what: even after installing Lubuntu it still works!

So my conclusion is: the problem of not working of my HP Laser 107w wasn’t a Lubuntu issue at all: it was probably a computer hardware fault.

Again: thank you very much, Fritz, for your great suggestions: it really brought me to think it over again and to re-installing it, which gave me the solution, and which affirmed that it wasn’t a Lubuntu issue at all!

Therefore, I will mark this topic as solved.


Sorry admins, I don’t know how to mark this topic as ¨SOLVED"! :face_with_open_eyes_and_hand_over_mouth:

Here are several links you could try.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.