How to enable Japanese Input on Lubuntu 22.04LTS?

I appreciate EVERY bit of help I got here, and yes, will be happy to do a quick check from a Live install, just might have to take a few days to get to that. But I’ll post the results here. Yes, I know there’s iffiness about installing odd packages, but sometimes that’s just how things happen. The irony is that I may not even need that package after all…Handbrake may actually offer the features I need. But I’ll check into that other Sub package too. It was for a project that I’m mostly done with. And I’d say I know (despite this thread!) more about Japanese input than about subtitles!

Again, thanks, @wxl and I’ll be sure to check this out on a Live Lubuntu shortly.

2 Likes

Thanks, I appreciate it— or rather future users wanting to use Japanese input will!

Anyways, if you ever need help finding software packages for a particular task, let me give you a few suggestions:

  1. You can, of course, use Discover, our software store to search for keywords (although it doesn’t show everything)
  2. If the command line doesn’t bother you, apt-cache search keyword can search the archives (which you can grep to your hearts content to get it fine tuned to exactly what you want)
  3. You can search through the archive at packages.ubuntu.com
  4. You can always ask here! (this is really a good choice if there are multiple candidates as we tend to be sensitive to those things which add unneeded dependencies)
  5. askubuntu.com is not only a good place for help in general but also can help you find the software you might need
  6. Sometimes asking for help with communities tied to your specific needs can be helpful. For example, were I in need of help with anything related to audio/video, I’d probably ask the Ubuntu Studio folks.
2 Likes

Thank you, again, @wxl, this will be very useful in the future. I started using Linux in 1999, when things were all done by command line (at least to start), and often do apt searches (with grep). BUT, I find myself in trouble when posts (You’ll see one in Ubuntuforums, I didn’t post in askubuntu as I try to not cross post…but here, this group seemed more technical) don’t get any replies. In this specific case, I was following an old thread on creating subtitles (from 2009, I think) and did (just as you or someone else surmised!) use “–force” to install that bdsup2sub. I tried everything before, seeing if it would go in with apt, etc., but “resorted” to that because it’s what the directions called for. If you veer off into guessing about stuff it gets very easy to make mistakes. But I can assure you that the “bdsup2sub” was installed long after I’d given up getting Japanese input to work. :smiley: That’s usually one of the first things I try when I update or reinstall…and it didn’t work. But I didn’t have your little howto then either.

So I’ll put in a Live CD and give this a go. Fingers crossed!

Historically, I have loathed forums, which is why I don’t think you’ll find a single post from me on the Ubuntu Forums. Discourse makes forums tolerable for me. More than that, though, I always get the feeling like a lot of the information/posts there are old and outdated, much like the Ubuntu Wiki is. And the fact of the matter is that in the Linux world, things change fast. I mean, it was only a few years ago that Lubuntu was using LXDE!

The other advice I’d give about taking advice is make sure you know what you’re doing before you do it, especially when it comes to command line stuff. For example, man apt-get provides a pretty stern warning about that switch you used to install bdsup2sub:

       --force-yes
           Force yes; this is a dangerous option that will cause apt to continue without prompting if it is doing something
           potentially harmful. It should not be used except in very special situations. Using force-yes can potentially
           destroy your system! 

Be thankful you only got the “potentially harmful” part and not the “destroy your system” one :wink:

2 Likes

I have, ahem, destroyed my system more than a few times. Sometimes it’s been recoverable, othertimes not. Gradually those vast epic fails have become far and few between but they still happen. I will definitely be more cautious about “–force” in the future…and about using 3rd party .debs. Excellent advice!

And yes, that’s totally the case: Things change so quickly. I wrote down the instructions for doing Japanese input for 18.04 and maybe even the previous LTS. But they change, the wordings differ, the placement of X or Y or Z shifts…and it gets hard to follow unless you REALLY know what you’re doing.

2 Likes

You might look into the backintime-qt package as a way of taking snapshots of your system before making potentially damaging changes. More info about it on their GitHub and docs.

Another thought: before making changes, try them out on a live system and see what happens. It won’t be an exact replica of your system, but it should include a lot of the major parts.

1 Like

I will save thesun the trouble, as I had already tested this beforehand,

mozc IME on iBus

Install ibus and mozc support
sudo apt install zenity im-config ibus ibus-mozc mozc-utils-gui

Choose IM framework ibus
Preferences > Input Method > OK > Yes > ibus > OK > OK
logout
login

Add the widget to the panel
LXQt Panel> Manage Widgets >
if not already, Add Status Notifier.
if not already, Add System Tray. (maps old software to Status Notifier)
Close

Add Mozc to the widget
LXQt Panel> right-click EN> Preferences>
Input Method> Add (Japanese > Mozc > Add) > close

Toggle widget on the panel
LXQt Panel> left-click EN> Japanese-mozc
LXQt Panel> left-click A> Input Mode(A) > Hiragana
Start Typing.
!---------------------------------

mozc IME on fcitx

Install fcitx and mozc support

sudo apt install zenity im-config fcitx fcitx-mozc

Choose IM framework fcitx
Preferences > Input Method > OK > Yes > fcitx > OK > OK
logout
login

Add the widget to the panel
LXQt Panel> Manage Widgets >
if not already, Add Status Notifier.
if not already, Add System Tray. (maps old software to Status Notifier)
Close

Add Mozc to the widget
LXQt Panel> right-click EN> Configure>
Input Method> ‘+’ (to add) > UnTick (Only Show Current Language) > go to bottom > Mozc (select) > OK > close

Toggle widget on the panel
LXQt Panel> left-click EN> (icon changes)
or
LXQt Panel> right-click EN> Input Method > Mozc
Start Typing.
!-----------------------------
This was done on 24.04 live
Notes :

Status Notifier needs System Tray.
The framework switcher (im-config) needs zenity (which was slow).

Where you see EN above, maybe only the keyboard icon.

ibus mozc :
The default keyboard toggle was Super+Space,
although this didn’t work, but Shift+Super+Space did work.
You can change this to Ctrl+Space in wth widget preferences.

fcitx mozc :
The default keyboard toggle is Ctrl+Space,

1 Like

Hey, so I guess great minds think alike, I was also booting into a Live CD and tested this out. Here’s what worked for me. It was almost the same as the steps above but with a few small differences, all done from a fresh untouched Live CD:

  1. sudo apt install language-pack-ja
  2. sudo apt install fcitx-mozc
  3. At this point I couldn’t find fcitx in System Tools, even after logging out and logging in. However, when I tried to run “fcitx” at the command line it gave an error and suggested installing “fcitx-bin”…so…
  4. sudo apt install fcitx-bin
  5. NOW this was visible in System Tools. I again logged out and logged back in.
  6. Right click on the keyboard icon and clicked “Configure.”
  7. Lo and behold, two languages were showing: English, and Mozc. I did not have to do step 7 or 8 or 9 from the original instructions. Not sure why, but that’s how it was.
  8. Opened Featherpad and tested, and it worked great.

So that’s what worked for a Live CD, 22.04LTS.

Thank you again, all, for the help and suggestions and clear instructions.

One last question, regarding that “backintime-qt” package, which I will check out. Is there any way to know what packages have been added that were not part of an original vanilla install? For instance, I’d love to be able to – just prior to upgrading – remember that I’ve installed bdsup2sub or inkscape or the umpteen different things that I install. I’d love to have a list of things to refer to so that I could spend a day (or write a script, perhaps) that will run through and “sudo apt install” all these in one go, rather than sit down and want to edit a video and realize I don’t have the videoeditor of choice installed.

(Maybe a different thread, happy to call this Japanese input one closed! But perhaps there’s an easier way to do this than what I’ve been doing, which is basically discovering as I go along each time what’s missing and what I need to reinstall…)

1 Like

Why are you installing this? It has GTK dependencies, so not ideal for a Qt-based desktop environment like LXQt.

Lots of suggestions to be found here. Note however, that all this is checking is whether or not packages were manually installed. You can boot up the live system and nothing will be manually installed, but if you say, install lxqt-panel (which is, of course, already installed) the package management system will mark it as manually installed even though it didn’t actually install anything.

The cli suggestion was exactly what I needed.

comm -23 <(apt-mark showmanual | sort -u) <(gzip -dc /var/log/installer/initial-status.gz | sed -n 's/^Package: //p' | sort -u) > Packages.txt

This gives me a very useful list of things that have been added, and while you’re exactly right, it won’t be perfect, it’s hugely useful and all I need to do is scan through to see the ones that I need that might have otherwise been left until I wanted to use them only to find out they’re missing.

2 Likes

You a right. For a single framework installation
(only ibus or only fcitx), neither im-config nor zenity
is needed. (zenity is just used as a gui part for im-config).

im-config is only needed to switch between multi-IM frameworks,
e.g if you had both ibus and fcitx installed.
(you can also use im-config on the command line, which is why zenity is not listed as a dependency.)