How to add Chinese pinyin input

Hello. First time poster, so pardon me if I’ve placed my question in the wrong section.

I’m currently running Lubuntu 20.04. The iso was downloaded from lubuntu.me and the installation is fully updated.

I’m attempting to install Simplified Chinese input via Sogou. So far I’ve installed the fcitx-bin package and the fcitx-googlepinyin package from the Ubuntu repos, and the Sogou deb package.

At this point, I’m unclear how to activate toggling between English and Chinese. The documentation I’ve found online is inconsistent or outdated. I tried to follow several guides, and this one seems the most clear http://blog.zedyeung.com/2018/08/05/Ubuntu-18-04-fcitx-chinese-input-setup-google-and-sogou/ but I’m unsure how to proceed with the Lubuntu desktop instead of the standard Ubuntu Gnome desktop. Or even if this guide is correct.

I opened Fcitx Configuration but I can’t figure out how to actually use it. The farthest I got was adding Google Pinyin as a secondary input method. My goal is to be able to toggle between English and Chinese as the input method. It’s my understanding that Sogou is used in Ubuntu Kylin, so I’m sure there’s a way to install it on Lubuntu 20.04. Any help would be much appreciated!

1 Like

Go to input method and select fctix

reboot.

after this you can add if you want several languages in fctix configuration.

you will see that at that moment an icon appears on the taskbar

screen

By pressing the right button on it you can continue configuring or simply switch between the two languages.

you also have the option of support in Chinese.

1 Like

Thank you for the prompt reply. Unfortunately, I’m still unable to toggle between English and Chinese. I followed your instructions and was indeed able to switch the input method to Chinese, and the pinyin input works, but after I toggle it back to English, it still uses Chinese input. I tried changing both the ‘Input Method’ and the ‘Configure Current Input Method’ back to English, but it doesn’t change anything. I had to type this reply on another computer since I my keyboard is stuck in Chinese. I will continue to experiment to find a solution, but I’d be grateful for any additional help. Thank you again for the prompt reply.

1 Like

First, I would strongly recommend @Noumeno 's suggestion of using our Chinese support section. While that does exist here, that doesn’t mean that those reading the English support section read Chinese very well at all. I certainly can’t. So even where you link to Sogou’s website, it’s a challenge to me to figure out where to download the Debian package.

The sad, sad fact is that nearly all of the Lubuntu Team’s developers are native English speakers and have never had the need to switch input methods or keyboard layouts. That’s not a technical problem, but a cultural one, and it’s a doozy! We’ve been working really hard to add additional support and I’ve been really delighted by that but if those of us with the advanced knowledge necessary to answer difficult questions don’t have a compatible communication methodology, that doesn’t work so well.

I will also add that the Lubuntu Team guarantees support for what we ship, i.e. what comes with Lubuntu and what’s available in the Ubuntu archives. Anything outside of that is ultimately beyond our scope. We can’t guarantee compatibility with anything we’re not already packaging. That said, I think your really best option is to either inquire with whomever is developing Sogou or perhaps with the Kylin developers. Kylin uses a different desktop environment but I believe they use fcitx or at least should be familiar enough with it to help. Note that any advice you give for other input method managers (like iBus) are likely not directly applicable to fcitx and may be frought with other issues (a long time ago we used iBus and I remember problems).

Additionally, I will mention that if you’re using keyboard shortcuts, which I think is a common thing for people to do when switching between input methods or keyboard layouts, one thing you have to be cautious of is all of the other shortcuts. Are there conflicting shortcuts defined in the global shortcuts or in Openbox or in the application you’re working with? These are all important questions to answer before making any conclusions about how well keyboard shortcuts are working.

Recently it was brought to my attention that there seems to be some sort of bug in the keyboard layout shortcut handling for some layouts. There could be a similar bug with fcitx, but as it has a broader scope than LXQt (only a few distros use LXQt but LOTS, all with different desktop environments, use fcitx), I think the likelihood is much less. One thing you might want to do is only use the system tray icon to switch because then you eliminate any likelihood of shortcut conflicts.

Of course, that may be what you’ve already done. Meanwhile, I’ll try some experimentation and see if I can figure anything out. I hope that the information above will prove helpful and eliminate the need for it!

1 Like

@wxl
Thank you for yout thoughtful and frank reply. I understand that non-English support is largely cultural rather than technical, so your helpful reply is very much appreciated. I’ve been a happy Lubuntu user for many years, and I have always held the Lubuntu developers in high esteem, especially considering how much work is required of such a small team. And much respect to the Ubuntu developers as well. Working across cultures is challenging, no matter one’s technical skills.

I’ve continued searching for a solution to my problem, but I’ve been unsuccessful. Keyboard shortcuts don’t work but they are the least of my worries, since I’d be happy toggling with menus. However, after much experimentation, I have figured out that some text boxes behave differently than others. Sometimes English input works for a short time, but somehow it doesn’t stay that way. Some non letter keys like the dash or space bar stopworkinglikerightnow. hitting the spacebar switches to Chinese but only sometimes.It makes no sense. I have to copy spaces and paste them between words, but only sometimes. I haven’t yet determined what is triggering the changes in keyboard input, since I haven’t used Ctrl, Alt, Fn, or any super keys.

I’m reluctant to use the Chinese support forum, or Kylin, since I’m not a native Chinese speaker, and my Chinese is still beginner to intermediate level. My need to install Chinese pinyin input is for a language class at school.

I very much appreciate your efforts to find a solution. If the problem is with LXQt or something Lubuntu-specific, I’d be willing to try another Ubuntu flavor instead. (Even though Lubuntu is my favorite.) Ubuntu Kylin would be my last choice, since it’s a bit over my head, but I will install it if I have to. But I wouldn’t mind using Ubuntu Mate, Xubuntu, Kubuntu, or vanilla Ubuntu if there is some kind of up-to-date documentation I can follow. My class requires Ubuntu 18.04 or 20.04 if we choose to use Linux, and Sogou input is preferred but not required. (My teacher uses Windows in class but is very Linux-friendly.)

I will continue to look for a solution, and I’ll contact Sogou support as well.

Thank you again for taking the time to address this topic. I know it’s not an easy one, primarily for cultural reasons. The Lubuntu (and Ubuntu) devs and community always go above and beyond when it comes to such challenges.

Cheers.

3 Likes

Not being a native Chinese speaker certainly presents a whole new set of problems! :wink: Although for us, it’s actually quite good!

Anyways it looks like you’ve ruled out shortcuts as being a problem.

I think if we simplify this problem, it might help.

So here’s what I did that seems to be working correctly:

  • Setup
    1. Do all the above to set up fcitx as the default input manager
    2. Install the fcitx-googlepinyin package
    3. Logout and back in again
    4. Open the fcitx configuration and ensure that Google Pinyin is added as an input method (it was by default for me and did not require me to add it, but just double check)
  • Test
    1. Open Featherpad
    2. Start typing. Results in normal English
    3. Either click on the icon or use CtrlSpace to switch to the other keyboard layout. The icon should change to a Google “G” logo, albeit in black and white: 2021-01-22-130446_28x28_scrot
    4. Start typing. Results in Chinese, with expected suggestion window shown:
      2021-01-22-131029_475x183_scrot

I admit to testing this in the development version of Lubuntu (and actually I’m running some package versions of LXQt not even released in Ubuntu yet), so that may be the difference. I hope not. If you can’t replicate these results in 20.04, I can try again in that version.

However, if you can replicate my results, it suggests your problem may lie either in Sogou or the methodology you used to install it.

P.S. Thanks for the kind words. Speaking for the team, we appreciate it!

2 Likes

Ok. I reinstalled Lubuntu 20.04, updated it, and reinstalled all the Chinese packages from scratch. It’s working, but oddly. Ctrl-Space toggles between English and Chinese, however, when it’s in English mode, hitting the spacebar alone will toggle it back to Chinese mode. When in Chinese mode, the spacebar alone does nothing. Yet in both English and Chinese modes, Shift-Space will cause a space to be entered. I can probably live with this, but muscle memory for typing spaces is kind of annoying. Any idea why Shift-Space works in lieu of Space? At least there’s been progress, and I have something usable for now, while I troubleshoot the spacebar issue. If you think 20.10 would work better, I’m sure I could use it instead. Again, thank you for the prompt and helpful replies. You guys rock!

Are you doing that all with Google Pinyin as in my test or Sogou? If the latter, I’d advise starting over and using Google Pinyin. That way we can compare apples to apples, ok?

Good catch. I installed both Google Pinyin and Sogou. I will try again per your instructions. I have to go to work now, but I will try again after work. Thanks again!

Sounds good. We’ll get this figured out eventually!

1 Like

thanks @wxl for the help, it’s always a pleasure your help!

1 Like

Actually it helps me a lot, too. I really need to get a better handle on input methods and keyboard layouts but never having the need to mess with either, I’m a little in the dark. Having folks well-equipped to speak English that need to use them actually helps out quite a bit!

1 Like

It works!

I reinstalled Lubuntu 20.04 while on my break, updated it, and then installed the aforementioned fcitx packages, but did NOT install Sogou this time. I then configured fcitx and rebooted. Problem solved!

Perhaps the Google Pinyin package conflicted with Sogou before. The keyboard shortcuts and language input now work correctly with just Google Pinyin. While Sogou seems to be the most recommended Chinese language package, Google Pinyin works great from what I’ve tested so far, and will certainly suffice for my language class. If I ever need an input method that is different or more sophisticated, I’ll cross that bridge when I get to it, by which time I’ll probably be able to write better Chinese than I currently do. So far, all the Chinese sentences I’ve written with Google Pinyin have been easy to do and the Pinyin recommendations match what I’ve learned in class.

@wxl 谢谢! Thank you for all your support. Your patience and insight have helped tremendously.

Cheers.

2 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

Hey just to put a final word on this (indeed given that it’s closed), I was able to get Sogou working and alongside Google Pinyin no less. I talked to one of the lead developers for Ubuntu Kylin and they do indeed ship Sogou. Because it’s proprietary software, it’s not included in the Ubuntu archives, but they say it’s the best solution. They’re actually now shipping an enterprise version of it, too, for extra fanciness.

Anyways, so you go to the main Sogou page and there’s a little slider at the top. The first slide is for Sogou proper. The second is for Shuangpin which is for older release versions. Look for “立即下载” (“download now,” I’m told) and click on it.

That will take you to a page with further instructions while at the same time downloading the Debian package. Save the package rather than installing it. At time of writing that will get you sogoupinyin_2.4.0.2942_amd64.deb (and FWIW the URL is here).

Now install it with sudo dpkg -i ~/Downloads/sogoupinyin*.deb. You will get an error about the installation not completing due to dependency issues. Fix this with sudo apt-get -f install.

Now, assuming you have fcitx already set up (see above if not), the installation should have already added it to your input methods in the fcitx configuration but you may want to check or reorder.

Now you just use it like normal. It’s very clear when it’s working right because not only does it have a system tray icon with a badge featuring their “S” logo, but there’s also a little popup just above the system tray:

If you have troubles, I’d probably go talk to either the Sogou folks or the Kylin folks, especially given the proprietary nature of the software. I can tell you that handsome_feng speaks incredibly good English and is super duper helpful.

2 Likes