How can I change which software is used to open folders?

I installed thunar (pcman sometimes needs several seconds to open folder - I want to switch to a different file manager to distinguish between pcman being buggy and my drive dying)

I went into configuration center, selected file associations, inode section, directory - and changed default software.

It is completely ignored, went into this setting and it is as I set it.

How can I change which software is used to open folders?

I tried rebooting.

I did sudo apt update && sudo apt upgrade (and discovered that its CLI log now includes an ad)

Try Ubuntu Pro beta with a free personal subscription on up to 5 machines.
Learn more at
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.5 LTS
Release:        20.04
Codename:       focal

Is it really necessary and useful to include lshw, lscpu, lsusb, and lspci /var/log/syslog /var/log logs?

1 Like

What happens if you pop open a terminal with Ctrl+Alt+T and then run the xdg-open / command? The slash at the end is important. This should open your root directory. Does it open in Thunar or PCManFM-Qt?


It opens Thunar.

Nevertheless when I double click folder on desktop - it opens it in PCManFM-Qt.

The desktop icons are part of PCManFM-Qt, so naturally it opens folders using itself (like the file-window).
You can change that with;
right-click the folder > Open With… > Other Applications > Set selected application as default action…
(this will also set it for the file window too).

Alternatively you can install another app to handle desktop icons.

1 Like

Have you tested it? For me it does not actually change the default.

How can I do this?

Yes you’re right, the setting doesn’t stick with Pcmanfm-qt.

I used spaceFM (a fork of pcmanfm) I had assumed they
work the same way but they don’t.
In SpaceFM (also a file-manager + desktop manager) There’s an option in Preferences> Open folders using associated MIME application.
Pcmanfm-qt does not have this.

How can I do this?

It sounds easy but it’s fiddly.

To replace Pcmanfm-qt’s desktop part, you can install another
combo (like SpaceFM) and only use the desktop part (the desktop session), which manages the desktop and icons.
You can just install a standalone desktop/icon manager e.g
xfdesktop4 or iDesk.

Either way, you have to make sure that Pcmanfm-qt’s desktop part never autostarts. You click this off with
Preferences > LXQt Settings > Session Settings > Basic Settings
and toggle off ‘Desktop’.

You also have to put in your replacement;
sudo cp ~/.config/autostart/lxqt-desktop.desktop ~/.config/autostart/my-desk.desktop

and change Name and Exec to reflect your new desktop manager
(for xfdesktop4 it’s xfdesktop)
(for spacefm it’s spacefm --desktop)

I can’t comment on idesk, cos I never tried it. But I can
confirm that the desktop can open folders following the mime type you set in LXQt’s File Association if you install either
xfdesktop4 or SpaceFM.

It works for folders or shortcuts to folders.
It does not work for desktop Entries that point to folders;
e.g user-home.desktop
[Desktop Entry]
Exec=pcmanfm-qt /home/someuser

Here, you have to edit the desktop file and change pcmanfm-qt to thunar.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.