Help with Arduino Install please

I had downloaded and installed Arduino and it worked well until I shut my laptop down. When I powered back up another day Arduino would not run. I deleted it and tried to reinstall with the same wget commands that I had used before but this time it will not install. I have a desktop Icon but it never opens.

And now I cant upload an image.

I know nothing about Arduino so can only provide minimal comments.

You didn’t mention any release details, my guess is 18.04 & LXDE by the bottom left hand corner of the image you provided.

The error on your screen implies to me the script assumes it’ll only be executed once, and thus doesn’t have error checking inbuilt should it have been run before (and thus error where prior link exists). Look at the script & adjust it, or rm the link so your system matches the expected behavior.

The error messages shown I’d not expect to create issues, however as I can’t read the script, I don’t know if it aborts on any unexpected condition thus this minor glitch is more significant than I’d expect.

A snap version exists, but given I don’t know anything about it, it maybe something different

Some people read the documentation before installing a new software.
But “real experts” are using sudo everywhere, even if it is not needed.

The script (1.8.13, I assume it is the same for 1.8.12) checks for the argument -u, --uninstall to remove all the installed files.
Less experienced people would use directly ./ to remove Arduino IDE.
But “real experts” need: sudo ./ --uninstall to remove the files and symlinks.

1 Like

What are you saying with the “real expert” thing? I simply copied what was on I only did the old right click delete on the original program then used $ wget to redownload. What command should I have used to completely remove it and what command should I have used to install?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.