Help: Wifi adapter RTL8822be not working with 20.10

I just upgraded my laptop from 20.04 LTS to 20.10 yesterday.

Since 20.04, my wifi adapter RTL8822be didn’t work with default installed driver. But I could get it work with the method mentioned here

With 20.10, again the wifi adapter doesn’t work with the default driver. However, above method doesn’t work any more. When i tried to run ./make, I got following error message. And the git repository has been discontinued.

./include/linux/vermagic.h:6:2: error: #error "This header can be included from kernel/module.c or *.mod.c only"
    6 | #error "This header can be included from kernel/module.c or *.mod.c only"
      |  ^~~~~
make[1]: *** [scripts/ /home/maweimin/Downloads/r8822be/rtl8822be/trx.o] Error 1
make: *** [Makefile:1780: /home/maweimin/Downloads/r8822be] Error 2
make: Leaving directory '/usr/src/linux-headers-5.8.0-34-generic'

The git owner mentioned also to try the latest rtw888 driver at But is says “IF YOU RUN UBUNTU, YOU CAN BE ASSURED THAT THE APIs HAVE CHANGED. NO, I WILL NOT MODIFY THE SOURCE FOR YOU. YOU ARE ON YOUR OWN!!!”.

I am not a good deep-user of Ubuntu/Lubuntu. Could anybody help me to get the wifi adapter work again with 20.10?

1 Like

I would suggest filing a bug against the kernel. Perhaps support for this card has been dropped? I can’t imagine that’s the case, but perhaps it’s true due to licensing issues or something of the sort. Either way, this is not a Lubuntu-specific issue, so you might get more luck with the bug and/or AskUbuntu.

Did you try to compile rtw_8822be driver on Larry Finger’s git (the second link you gave). He is the rtl man. I have an rtl8723ae wireless and had to use his driver until it got into the mainline kernel. If it compiles and builds successfully do a:
lsmod | grep rtw

If you see any module other than rtw_8822be rtw_core rtw_pci you have to blacklist it.

If that fails nobody in Lubuntu can help you. Try Ask Ubuntu and the mailing list suggested by LF:

When you have problems where the driver builds and loads correctly, but fails to work, a GitHub issue is NOT the best place to report it. I have no idea of the internal workings of any of the chips, and the Realtek engineers who do will not read these issues. To reach them, send E-mail to Include a detailed description of any messages in the kernel logs and any steps that you have taken to analyze or fix the problem. If your description is not complete, you are unlikely to get any satisfaction.

If wireless is a must and I think it is, use the Ubuntu version that works until the problem is solved. I had to dual-boot Windows for a year some 9 years ago. The minute I had a working driver I erased Windows.


I forgot to add. You can try to use a working kernel (an older one) but I do not know how to do that in Ubuntus. So, you will have a 20.10 base but maybe a 5.4 or 4.9 or whatever kernel. Just a thought.

1 Like

Thank you guys. I have made my wifi adapter successfully run by

  1. creating rtw_pci.conf in /etc/modprobe.d
  2. adding one line “options rtw_pci disable_aspm=Y” in that file.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.