Help: Running 20.10 and it doesn't seem to recognize my capture card

I can’t see to get lubuntu to recognize my Zoran based capture card (IOmega Buz). Here is what I have done so far and got stuck.

  1. lspci | grep Zoran
    06:09.0 Multimedia video controller: Zoran Corporation ZR36057PQC Video cutting chipset (rev 01)

  2. sudo dmidecode -t 2

dmidecode 3.2

Getting SMBIOS data from sysfs.
SMBIOS 2.4 present.

Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: GA-MA790FXT-UD5P
Version:
Serial Number:

Is there support for AMD 790FX chipset?

  1. checked Kernel dot org (http://kernel.org/) section 35.2.1. Iomega Buz

unified zoran driver (zr360x7, zoran, buz, dc10(+), dc30(+), lml33)

I think this should cover my card

  1. Tried steps outlined here
    35. The Zoran driver — The Linux Kernel documentation

Looking for the Zoran conf file but it’s not there

  1. Load zr36067.o.
    How do I do that?

  2. run ‘v4l-conf -c ’
    what do I use for the device? Is it some part of what I found in lspci? The numeric portion (is that an ID?)

How do you know it’s not working? lspci -nnk will tell you the state of the drivers. My guess is it’s already loaded.

Hi wxl, Thanks for the reply and help.

I assumed the drivers are not loaded because I couldn’t find the config file in Step 4… and when I use VLC, OBS studio, or Qt V4l2 test utility… I don’t see a video source like I do for things like webcams etc…

using this seems to give me the same output as my step 1… is there something I should be looking for?

06:09.0 Multimedia video controller [0400]: Zoran Corporation ZR36057PQC Video cutting chipset [11de:6057] (rev 01)

Are the values in brackets usful for steps 5 and 6?

Forgot to mention I also tried kenlive… app can’t seem to see it as a source.

The key is the -nnk part.

Here’s lspci alone on one of my devices:

04:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)

And here it is with the additional flags:

04:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX150] [10de:1d10] (rev a1)
        Subsystem: Hewlett-Packard Company GP108M [GeForce MX150] [103c:8389]
        Kernel driver in use: nouveau
        Kernel modules: nvidiafb, nouveau 

Interesting using the -nnk I the only extra info I got were the values in the square brackets… nothing for Kernel Driver in use or Kernel modules… can I take that to mean the driver is not loaded?

Unless you did some other processing (e.g. grep) to trim down the list, that’s rather strange, as it would suggest that there are actually no drivers in the kernel. This is unexpected behavior. I assume modinfo zr36067 produces some output? If so, try sudo modprobe zr36067 and try lspci -nnk again. If it still is an issue look for errors in your logs (journalctl).

1 Like

Here is what I see. It’s th elast entry with nothing for drivers… but the above entries have drivers.

I had read that I might want to see if there are any IRQ conflicts… any suggestions on how to look at that?

modprobe: FATAL: Module zr36067 not found in directory /lib/modules/5.8.0-41-generic

Couple things in red:

__common_interrupt: 1.55 No irq handler for vector

many lines of:
ACPI Error: AE_NOT_FOUND, While resolving a named reference package element - LNKC (20200528/dspkginit-4>

Some other lines that look like they are about network connections but I’m not 100% sure… not sure what to look for and it’s too long to take a screen shot :slight_smile:

thoughts?

Seemingly inexplicably, it has been dropped. In Bionic, it exists. In Focal and beyond, it does not. This is consistent with Debian, too. I looked through the changelogs and the drop is not documented.

…that is, until I looked through the not-so-easy-to-parse upstream changelogs and found this that saw the light of day with kernel version 5.2:

The zoran driver has been marked deprecated for a year now
without any interest to update this driver to the vb2 framework.

Time to remove it altogether.

If I read between the lines, it seems like some work is being done to get it fixed up, but it’s not done yet based on the TODO I found:

TODO
- fix the v4l compliance "TRY_FMT cannot handle an invalid pixelformat"
- Filter JPEG data to made output work

Long story short, newer versions of *buntu are going to be problematic in this regard. You should use Bionic (18.04).

Given that it should Just Work™. You can read about modprobe to set parameters if need be.

2 Likes

Thanks you so much for your help. I have a dumb question.

If it was removed then to get it working in 20.10 is it just a matter of installing the drivers or might there be compatability issues and that is why it’s better to go back to 18.04.

Looking at lubuntu.me threre is this 18.04.5 Bionic Beaver LTS (LXDE)… is this what I should use? I guess I should just install that to a separate partition and see if it works easily or has surprises. sadly my fall back plan is to resurect some old hardware to install WindowME (scary).

I am no kernel developer but this “vb2 framework” suggests to me that some fundamental architecture changed and the driver needed to change with it. That said, I don’t think (but don’t know) that the old driver on a new kernel would work. An old kernel would work, but that presents a whole different set of issues.

In the end, 18.04 would be the better solution, as you found.

As an alternate fall back, you may be able to use Windows in a virtual machine with PCI passthrough to access the device.

However, before I go that route, you might want to actually get in touch with the developers and ask for advice. You’ll notice they do have a mailing list.

Thanks so much for you help. Learning linux ad hoc has been hard and I am so grateful you were willing to give me so much effort.

Took a while… had prolems with my SSD and then it died… but got 18.04 installed… but still not working. Is the kernel still too new? Do I need to go further back? Where do I get older versions and how old do I need to go? What version was it depricated?

Um, that’s weird. You should have a version 4 with Bionic, not 5.

This is the one I downloaded:
https://cdimage.ubuntu.com/lubuntu/releases/18.04/release/lubuntu-18.04.5-desktop-amd64.iso

During the install process I set it to NOT update while installing.

Grab the 18.04 (not 18.04.5) ISO and use that.

a realated question. When I boot up the live CD will it load drivers at that point? wondering if I can check to see if the kernel is compatible at that point or do I need to do the full install first.

When you boot, open a terminal and run uname -r just as you did before. As long as you don’t let it update (remember you can always just turn off/unplug networking), you should be on 4 not 5.

sorry for the back and forth I should have been more specific… will liveUSB load the PCI device drivers and I can do a lspci -nnk to see if there are drivers loaded or do I need to do an install.