GPU B renders much, much slower than GPU A

Kind of strange behavior exhibited from my new Lubuntu install. I have two video cards installed on my system and one renders much slower than the other.

Video card A is a RS880 [Radeon HD 4250] which is onboard and video card B is a RV730 XT [Radeon HD 4670] which is an addon PCI express card.

Video card B has less than stellar performance and it is especially noticeable using OpenGL.

Some details:
From lshw:
*-display
description: VGA compatible controller
product: RS880 [Radeon HD 4250]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 5
bus info: pci@0000:01:05.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm msi vga_controller bus_master cap_list
configuration: driver=radeon latency=0
resources: irq:18 memory:c0000000-cfffffff ioport:d000(size=256) memory:feaf0000-feafffff memory:fe900000-fe9fffff
*-display
description: VGA compatible controller
product: RV730 XT [Radeon HD 4670]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:02:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:25 memory:d0000000-dfffffff memory:febf0000-febfffff ioport:e000(size=256) memory:c0000-dffff

From uname -a:
Linux dinoPC 5.5.0-7.1-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix 5.5-10ubuntu1~eoan (2020-03-01) x86_64 x86_64 x86_64 GNU/Linux

From glxinfo | grep “OpenGL version”:
OpenGL version string: 3.0 Mesa 19.2.8

I’ve been driving at this problem for sometime now to no avail. Help would be very appreciated!

You haven’t mentioned your release of Lubuntu, but if it’s a new install your kernel doesn’t match any supported release of Lubuntu so it could be you’re running something that isn’t Lubuntu.

I would check what you’re running, or provide details on what you’ve done as details provided do not match a new Lubuntu install.

I’m sure I won’t have anything to offer. But, I’m curious. Which one is slower?

I am running Lubuntu and ‘lsb_release -a’ gives me:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.10
Release: 19.10
Codename: eoan

I am not using the stock kernel though, I am running the latest Liquorix kernel v5.5.0-7.1.

Video card B has less than stellar performance and it is especially noticeable using OpenGL.

And considering the kernel, not the desktop environment or the applications, is responsible for controlling the GPU, what makes you think that’s not the problem? I would go ask at Liquorix. Alternately, go try the stock kernel and if it’s a problem, report a bug in Launchpad. In that case, it will not be a Lubuntu problem, but one that affects all Ubuntu flavors.

1 Like

Turns out, same results using the stock generic kernel as well.

So I’d file a bug against the kernel in Launchpad… or given the fact that it might be the kernel in general, upstream!

So I was poking around and came across this:

http://forums.debian.net/viewtopic.php?f=6&t=77939

I read it and tried:

‘vblank_mode=0 glxgears’

The problematic video card ran full speed:

ATTENTION: default value of option vblank_mode overridden by environment.
37937 frames in 5.0 seconds = 7587.264 FPS
34374 frames in 5.0 seconds = 6874.700 FPS
38566 frames in 5.0 seconds = 7713.166 FPS
53974 frames in 5.0 seconds = 10794.649 FPS
54843 frames in 5.0 seconds = 10968.484 FPS

Well I think I have found a workaround. If I prefix problematic apps and games with ‘vblank_mode=0’ all is well. I do not know if this is proper but it works. Thank you everyone for the help!

2 Likes