Featherpad default font

Is there a way to set the default font that featherpad uses?

I’d suggest looking up the manual


To change preferences on how text is displayed choose the Text Tab. To have Featherpad remember what font you want press the Remember Font checkbox.

That only works for individual files I change it for.
Is that supposed to remember it for new files?

I just closed (featherpad was already open with two files I regularly leave open) & re-opened featherpad on my 19.10 system so it was ‘clean’. I changed the default font to “Ubuntu Mono” having “Remember font” checked as per the manual. I then closed featherpad.

On re-opening featherpad, the font is now “Ubuntu Mono”, and if I open my files from the “Recently open” they re-open but with the now “Ubuntu Mono” font.

This is my primary workstation, so my configuration will have been modified many times, but it does what I believe you want on my system.

I had a pretty-clean (QA-test install) 19.04 system ‘up’ (to answer a ask.ubuntu question) so went and looked there. Opening featherpad there had no recently opened files (expected; it’s unused) and had a different font to my primary 19.10 system). I changed the font there from “Monospace” to “Ubuntu Mono” and ensured the “Remember font” was checked, then exited featherpad. On re-entry of featherpad and starting to type, the text was being displayed in “Ubuntu Mono” and checking the menu’s it appeared as “Ubuntu Mono” there too.

I opened featherpad and creates an “Untitled” document.
I change “Options/Font/Size” to 14 then click ok.
Then under “Options/Preferences/Text” I uncheck and check “Remember font”.
I then close and reopen featherpad and it is back to size 9.
Where are the preferences saved, I’ll delete the file in case it is corrupt?

I changed font and didn’t touch font point size (or font pitch for non-proportional/mono-space) as that is what I read your question about sorry.

I re-tested changing my default font pitch from 11 to 15, and had no issues on the very-clean 19.04 system, and my heavily modified 19.10 workhorse.

I would check your permissions for your ~/.config/featherpad/fp.conf file, mine look like

guiverc@d960-ubu2:~/.config/featherpad$   stat fp.conf 
  File: fp.conf
  Size: 2115            Blocks: 24         IO Block: 4096   regular file
Device: 3ah/58d Inode: 18849624    Links: 1
Access: (0664/-rw-rw-r--)  Uid: ( 1000/ guiverc)   Gid: ( 1000/ guiverc)
Access: 2019-10-21 18:10:06.929771986 +1100
Modify: 2019-10-21 18:09:56.005585048 +1100
Change: 2019-10-21 18:09:56.021585326 +1100
 Birth: -

If your file permissions look correct (ie. you own the file) then you could always edit the file and put in the entries you want. I’ve only tested it using non-proportional fonts as it’s all I ever used in text editors.

This is not ideal, and I"ll provide it in hopes another user of this system has a better approach, but in my


file my new default font details looks like

font="Ubuntu Mono,15,-1,5,50,0,0,0,0,0"

ie. I’m using “Ubuntu Mono” font of size 15. I don’t know what the other are sorry. Please note: there is a lot in my fp.conf file, but I’ve only copied the font= line here.

1 Like

It was the ownership of the file:
$ ls -l ~/.config/featherpad/fp.conf
-rw-rw-r-- 1 root root 1387 Apr 3 2019 /home/rjl/.config/featherpad/fp.conf
I don’t know how that happened but I changed it and it worked.
Thanks for the help.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.