External screen on left

Thank you for the membership.
I have external screen on left I have no possibility to furnish. It is possible to put the external screen only to the right, and it can override in advanced settings, but then the panel gets to the external screen.
I tried with Arandr too, ticked LVDS1 as primary, but the panel is on the external screen anyway.

Which release of Lubuntu are you using?

Assuming you’re using Lubuntu 20.04 LTS, the Lubuntu manual page on monitor setup can be seen at


The LXQt config in that section of the manual doesn’t impact sddm or where you login, but your login details should appear on all displays. Once you login the saved settings take effect.

I use 18.04, Excuse me, I forgot this information. I tried 20.04 but I don’t intend to change to it because of several purpose.

Using the LXDE menu

Preferences -> Monitor Settings

opens Display Settings on my Lubuntu 18.04 LTS

In the advanced tab (at the top, click it), I can then change the following fields (check box or select)

Turn On | Position | Resolution | Refresh Rate

for each monitor. I can select

Default | On Right | Above | On Left | Below

in setting the position of an external monitor, in relationship to the thinkpad’s display.

If it’s the panel location you want to change, right-clicking the panel lets me select which monitor it’ll display on.

EDITED. Excuse me, this reply was wrong. My problem is that the panel is on the VGA-screen if I put it to the left. I should like to keep it in front of me, on LCD monitor.

You only have two displays, you can set the relationship of the two from the one you can change.

My own had only one option changeable too.

It would make no sense to be able to get both to “On Left”, so you set the one you can change to “On Left” or “On Right” as appropriate for your screen locations. If this isn’t what you mean, then sorry I’m not understanding your issue.

You answered to my wrong question I edited… :smiley:
Please, take a look there again.

My improved question is, how can I keep the laptop screen as primary if I have the external screen on the left side according to the advanced settings.

In Monitor Settings, select your laptop screen in the panel on the left. Then in the dropdown on the right, select “This is my primary display” and click the Apply button.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.