Epson wifi printers on Lubuntu 20.04

Hi to Everybody,

among the others, I have two Epson wifi printers: Workforce WF-2510 and Workforce WF-2630.

Both have the same problems on Lubuntu 20.04, while on 18.04 they regularly work:

  • scanner: this function doesn’t work, when skanlite tries to detect a scanner, it isn’t able to do it. Also the program suggested by Epson doesn’t work (iscan), but it doesn’t work also on 18.04 (here I use simplescan or gimp);

  • printing: after 3/4 works, both the printers get stuck, so I have to turn off and restart them. The printer led flashes and the printing work stops.

I’ve tried both with the generic escpr driver and the proprietary one.

Also the ink levels are not detected.

I’ve tried the installation also with the Cups interface from Firefox.

Thanks in advance for the help.

Nobody can help me? No Epson Workforce users here? :blush:

I would suggest using the live image of some other Ubuntu flavor, especially Ubuntu proper if you can. If they have the same problem, it must be some kind of driver issue and you could seek support from the wider Ubuntu community.

Also did you upgrade from 18.04 or reinstall?

Hi @wxl and thanks for your reply.

I manage several notebooks all running Lubuntu 18.04.

In two of these I’ve done a dual boot with Lubuntu 20.04 before to upgrade (reinstalling, I know I can’t upgrade with the usual command).

That two printers work well ‘under’ 18.04 (and Debian 10 LXDE, although here it lacks the LSB package).

Today I’ve done the usual updates with apt and… now the two printers apparently are scanning and printing! (no iscan anyway, it is not necessary but only to inform since Epson suggests to install it)

I didn’t make any change, only the normal system updates, then I turned on the printers to check some infos before to post here and… they work!

Might have been some regression that was fixed. You could always look through your /var/log/dpkg.log to see what was upgraded.

Unfortunately, the problems have appeared again…
I connect the two printers through an hotspot connection, the change between a smartphone to another is normally quite smooth (it changes the ip address, so I update it).
From today, cups discovers the two printers but then they don’t work and also the message in ‘printer state’ in system-config-printer is negative.
The command avahi-browse --all -t -r shows me the correct ip address the printers have… In Lubuntu 18.04 and Debian 10 they are currently work (on the same machine)…

I also add this strange behaviour in the image I attach when I try to do some action in system-config-printer…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.