Encrypted disk requires install USB inserted to boot

I’ve just installed the latest version of Linux from lubuntu.me (22.04.1) and installed. Everything’s gone well. I encrypted the disk, as I would prefer the extra security considering any sensitive docs.

The issue is that, now the machine will only boot with the installation USB inserted, and only if I go to the boot menu from the bios splash screen and select it (though, I expect it would do if it was ordered to the top of the boot list, too). After the USB is loaded, it goes to the master key passphrase screen. Otherwise, booting from the hard disk, it goes to the grub rescue screen.

I don’t mind this so much. It’s even somewhat more secure. I just think I ought to understand it. If this must happen, fair enough, but I’d like a copy of the USB stick. The USB key has no other partitions on it. I’ve tried copying the contents to another USB stick, and tried to boot from that, and it does work.

Is this a standard configuration? Perhaps I checked a box on install without realising. If so, how can I replicate the USB stick so that I have a spare?

Thanks in advance.

1 Like

Please boot your installed system, open a terminal and show the complete input and output of:

sudo parted --list
sudo efibootmgr -v
sudo blkid
cat /etc/fstab

This is definitely not normal - you should be asked for a passphrase when you boot (though you’ll only see a very simple text prompt when doing so). Upon providing it and hitting Enter, the system should appear to freeze for several seconds, then unlock and boot normally. No USB needed.

The info @apt-ghetto is asking for should help us debug what’s happened wrong - perhaps you tried a non-standard installation and so something isn’t quite working as expected? Also, did you by any chance attempt to set up a dual-boot system? Lastly, is it possible that you installed Lubuntu to an NVMe drive on a system that does not support NVMe boot?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.