Deactivating and activating the external speakers on a standalone PC after every reboot in Lubuntu 21.04

on a standalone PC with external speakers (connected by USB and audio jack) I installed Lubuntu 21.04;
in the live-version the speakers didn’t work; but after the installation they worked;
then after the update, executed in the terminal, this is what I need to do to make the speakers work after every reboot:

click on the panel on the speaker-symbol; click on “Mixer”; click in the tabs on “Configuration”;
click the checkbox in the “Built-in Audio” “Profile” (Analog Stereo Output) to deactivate;
click again the checkbox in the “Built-in Audio” “Profile” (Analog Stereo Output) to activate

if you need more informations about the PC: sudo lshw -C sound:
*-multimedia
description: Audio device
product: Celeron/Pentium Silver Processor High Definition Audio
vendor: Intel Corporation
physical id: e
bus info: pci@0000:00:0e.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:25 memory:a1310000-a1313fff memory:a1000000-a10fffff

Is there a way that I don’t need to deactivate and to activate the extenal speakers after every reboot?

@ralf3u
You wish allways speakers working when starting Lubuntu ?

@aug7744

You wish always speakers working when starting Lubuntu ?

Yes, it would be great! That is exactly what I’m looking for.

Have anthing strange happening in your computer because the correct is always speaker be power on when starting Lubuntu.
You had tried connect in another USB port ?

I tried both possible USB ports. Same issue. No sound.
Is it because the speakers are very cheap (10 Euro)?

And there are more problems:
After a shutdown normally without speakers connected after 3 seconds the computer is off.
But with speakers connected, although the speakers do not work, after 3 seconds it takes another 10 seconds to be off, and afterwards there is a loud sound from the speakers, sometimes 2 times a loud sound from the speakers.

“Is it because the speakers are very cheap (10 Euro)?”
Not.
Try a test connecting the soeaker usb in cell battery charger and see if has the same issue.

There are no connections on a cell battery charger.
And I don’t like the idea to connect the speakers to a a cell battery charger.

If using an cell charger with usb connection will be good to test.
Perhaps will be need to disable usb power saving in your machine.

Oh, now I think that I understand what you mean:

Do you mean I go from the speaker with the audio jack in the computer, and from the speaker with the USB in the USB-slot of an USB-adapter that can be used for example to charge a tablet?

And what are the possibilities that will happen?

And how is it possible?

I connected the speaker with the audio jack in the computer, and from the speaker with the USB in the USB-slot of an USB-adapter that can be used for example to charge a tablet;

the result:

  1. deactivating and activating is still needed
  2. shutdown takes 10 seconds longer like before
  3. there are no sounds after the shutdown, but if I take away the electricity then there is sound

Should I buy a speaker with only USB-connection, so no audio jack?
Is the computer the problem?

“Is the computer the problem?”
You need see in BIOS all settings about USB.
What is your sound device ? sound card or mainboard integrated ?

speaker on ebay.de:
600W Speaker Mini Boxen Lautsprecher PC Laptop Notebook USB super Qualtiy S5 #B | eBay

I don’t know if a sound card or mainboard is integrated; details of the barebone-PC on kaufland.de:
MSI 8GL-002BEU - 0,45L Größe PC - Mini-PC | Kaufland.de

if you need more informations about the PC: sudo lshw -C sound:
*-multimedia
description: Audio device
product: Celeron/Pentium Silver Processor High Definition Audio
vendor: Intel Corporation
physical id: e
bus info: pci@0000:00:0e.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:25 memory:a1310000-a1313fff memory:a1000000-a10fffff

I not have much information about Linux, but the problem not is pointing to your speaker.
Perhaps related with drivers (not means being or not your sound device), a startup or and shutdown task needing timed processing.
You need post here startup and shutdown logs.
You need to acess the computer firmware BIOS (or UEFI) and see if has any setting about usb power saver.
Try for test access the BIOS and disable all cpu power saver settings and after finished tests return the settings to defaults.

If possible, please provide the output from the following command after experiencing the issue (with the speakers still connected):

dmesg | grep snd

I get the feeling @aug7744 might be on to something. It just might be the driver that’s loaded or it could be something else. Why performing an update to the system is causing this is still unknown to me but if you can please share the output text for the above command, I might get another clue.

with sudo it works; this is the answer:

[ 5.562897] snd_hda_intel 0000:00:0e.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 5.641558] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC283: line_outs=1 (0x21/0x0/0x0/0x0/0x0) type:hp
[ 5.641570] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 5.641573] snd_hda_codec_realtek hdaudioC0D0: hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 5.641575] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[ 5.641577] snd_hda_codec_realtek hdaudioC0D0: inputs:
[ 5.641579] snd_hda_codec_realtek hdaudioC0D0: Mic=0x19
[ 9.076717] snd_hda_intel 0000:00:0e.0: azx_get_response timeout, switching to polling mode: last cmd=0x20bf8100
[ 10.080388] snd_hda_intel 0000:00:0e.0: No response from codec, disabling MSI: last cmd=0x20bf8100
[ 11.092406] snd_hda_intel 0000:00:0e.0: azx_get_response timeout, switching to single_cmd mode: last cmd=0x20bf8100
[ 11.376304] snd_hda_codec_hdmi hdaudioC0D2: Unable to sync register 0x2f0d00. -5
[ 12.145908] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5
[ 12.146228] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x2b8000. -5

1 Like

Since today, I don’t need to deactivating and activating any more after a reboot!!!
Could it be because you changed some packages and because I made an update?
If so, thank you very much for your help!

But there is still a shutdown-problem:

  • instead of 3 seconds it still needs 13 seconds
  • there is still a loud noise in the second of the shutdown

And there is a new problem:
Since today on a notebook with Lubuntu 20.10 there is no sound at all. Yesterday it was working.
It seems to be that it happened after the update this morning.

These are the specs of the notebook asked with “sudo lshw -C sound”:
*-multimedia:0
Beschreibung: Audio device
Produkt: Broadwell-U Audio Controller
Hersteller: Intel Corporation
Physische ID: 3
Bus-Informationen: pci@0000:00:03.0
Version: 09
Breite: 64 bits
Takt: 33MHz
Fähigkeiten: pm msi pciexpress bus_master cap_list
Konfiguration: driver=snd_hda_intel latency=0
Ressourcen: irq:56 memory:c5218000-c521bfff
*-usb:3
Beschreibung: Video
Produkt: HP Webcam
Hersteller: Chicony Electronics Co.,Ltd.
Physische ID: 5
Bus-Informationen: usb@2:5
Version: 40.60
Seriennummer: 0x0001
Fähigkeiten: usb-2.00
Konfiguration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
*-multimedia:1
Beschreibung: Audio device
Produkt: Wildcat Point-LP High Definition Audio Controller
Hersteller: Intel Corporation
Physische ID: 1b
Bus-Informationen: pci@0000:00:1b.0
Version: 03
Breite: 64 bits
Takt: 33MHz
Fähigkeiten: pm msi bus_master cap_list
Konfiguration: driver=snd_hda_intel latency=64
Ressourcen: irq:57 memory:c521c000-c521ffff

These are the specs of the notebook asked with “sudo dmesg | grep snd”:
[ 6.715941] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 6.747538] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC3227: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 6.747542] snd_hda_codec_realtek hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 6.747545] snd_hda_codec_realtek hdaudioC1D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 6.747546] snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
[ 6.747548] snd_hda_codec_realtek hdaudioC1D0: inputs:
[ 6.747551] snd_hda_codec_realtek hdaudioC1D0: Mic=0x19
[ 6.747553] snd_hda_codec_realtek hdaudioC1D0: Internal Mic=0x12
[ 467.381116] Modules linked in: snd_seq_dummy snd_hrtimer rfcomm cmac algif_hash algif_skcipher af_alg bnep nls_iso8859_1 snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio snd_hda_codec_hdmi snd_hda_intel snd_intel_dspcfg snd_hda_codec snd_hda_core snd_hwdep joydev snd_pcm mei_hdcp intel_rapl_msr rtl8723be btcoexist rtl8723_common rtl_pci snd_seq_midi rtlwifi snd_seq_midi_event snd_rawmidi rmi_smbus mac80211 x86_pkg_temp_thermal snd_seq intel_powerclamp coretemp rapl uvcvideo rmi_core intel_cstate hp_wmi videobuf2_vmalloc btusb btrtl videobuf2_memops input_leds videobuf2_v4l2 snd_seq_device btbcm videobuf2_common btintel sparse_keymap wmi_bmof snd_timer videodev bluetooth serio_raw efi_pstore ecdh_generic mc ecc cfg80211 intel_pch_thermal mei_me libarc4 snd processor_thermal_device mei intel_rapl_common int340x_thermal_zone soundcore intel_soc_dts_iosf hp_wireless acpi_pad int3400_thermal acpi_thermal_rel mac_hid nf_log_ipv6 ip6t_REJECT nf_reject_ipv6 xt_hl ip6_tables ip6t_rt

You has done system updates ?

I have no clue what updates are available. If you did an update and it fixed itself, then it gives me the impression that something present on the system is causing the driver to act buggy. The reason I say this is because it appears the notebook you have runs the same driver and suddenly its also having problems. The output for dmesg command kind of supports this but that is just my hunch. I still don’t know what pieces are involved but what I feel is currently the most suspicious is the driver.