Cant login stuck at boot screen

I’ve shutdown the pc while a few apps was still running and now when i boot the Login screen load as normal but i cant use keyboard nor the mouse. The light on the Mouse are on. Rebooted a few times without success.
Is there a way to boot into a sort of recovery mode to fix this?
Lubuntu 18.04 lts x86_64
Intel i5-3570K (4) @ 3.800GHz
NVIDIA GeForce GTX 780

How did you shutdown your PC? Did you

  • use the menu and use the shutdown icon?
  • enter sudo shutdown -h now etc from terminal?
  • use SysRq keys to force kernel to shutdown?
  • or other?

The first three should have left the file-system in a clean state and next boot would not have been impacted; but a power-off for example may have left your file-system in a dirty state that complicates reboot, and the file-system should be checked & fixed (ie. fsck) before you attempt reboot.

If it was done in a dirty way, I’d suggest booting a ‘live’ system (eg. Lubuntu install media) and fsck or file-system check your hdd/ssd to ensure it’s clean, then try again.

Power-off (by pulling cord, or holding power button), should be avoided if at all possible and magic-sysrq keys used to shutdown; they aren’t magic but I use the term “magic sysrq” as in a search engine, it returns many useful entries to jog our memory.

I did use ‘the menu and use the shutdown icon’
Im running antix from usb. I do have access to the file-system.
Although, i dont know what to do.
‘file-system check your hdd/ssd to ensure it’s clean’ I dont know how to do that.

I don’t currently have time to write a detailed response currently, but I’d be using your ‘live’ system and use something like KDE Partition Manager to do it. Select your partition and right-click for the menu, select the “Check” option for each you need to check, then when done click the “Apply” at the top.

(I’d use terminal myself, but that would take longer to explain, and sorry I don’t know Antix)

Manual pages that may be useful :-

Ok. I’ve installed kde partition manager(partitonmanager)
Running as root, wont let me use the ‘check’ option nor unmount the drive. Is it because im running antix with static persistence?

If you just booted your ‘antix’, only the USB drive itself should be ‘mounted’ (though as stated I don’t know antix; but that’s behavior I’d expect from a Ubuntu/Debian). It’s possible you’ve selected the wrong 'device, and you need to navigate to your hdd/ssd first, then select your partition(s).

If ‘antix’ is GTK+ based, gparted will do the same thing (it’s what would come with Lubuntu 18.04 LTS too so may be more of what you’re used to).

Yep, i’ve tried GParted. GParted is installed by default in antix.
I thought maybe by deleting a specific file/folder i could boot into a sort of recovery mode or something similar. If that’s not possible, i’ll just copy every files i need and re-install. I’ll probably take the opportunity to upgrade to a newer version.
I’ll do that later this week.
In the meantime, if anybody knows a quick fix, i’ll be happy to give it a try.
Thanks for your time and support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.