Can't install Lubuntu 20.04

Hello, I’m trying to install lubuntu 20.04 on a Wyse DX0D thin client but i always get this error:

Errore da Boost.Python nell'operazione "bootloader".
Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=ubuntu --force' returned non-zero exit status 1.
Installing for x86_64-efi platform. grub-install: warning: Cannot set EFI variable Boot0012. grub-install: warning: efivarfs_set_variable: writing to fd 6 failed: Invalid argument. grub-install: warning: _efi_set_variable_mode: ops->set_variable() failed: Invalid argument. grub-install: error: failed to register the EFI boot entry: Invalid argument.

Traceback:
File "/usr/lib/x86_64-linux-gnu/calamares/modules/bootloader/main.py", line 457, in run
    prepare_bootloader(fw_type)

  File "/usr/lib/x86_64-linux-gnu/calamares/modules/bootloader/main.py", line 429, in prepare_bootloader
    install_grub(efi_directory, fw_type)

  File "/usr/lib/x86_64-linux-gnu/calamares/modules/bootloader/main.py", line 293, in install_grub
    check_target_env_call([libcalamares.job.configuration["grubInstall"],

  File "<string>", line 8, in <module>

I get the same error on other distros too and I’ve read somewhere to create the live usb via rufus with support for old bios/DD mode but that didn’t work either, I’ve also tried using unetbootin

I don’t know much about Wyze these days, but they’re thin clients without a whole lot of internal resources. In this case, I’d start at the beginning and first make sure you verify the iso’s integrity and try writing the data to USB with a different product - specifically giving Balana Etcher a shot. It’s worth the few extra minutes it’ll take to rule it out.

1 Like

I tried writing the usb with unetbooting and etcher too but I get the same result

2 Likes

I did some looking and is it correct that the Wyse DX0D only has 2 GB of storage?

I’m not sure that that’d cause those errors - but it might. I don’t think you can fit Lubuntu in such a tiny amount of space.

It comes with 16gb, windows 10 installs just fine and afaik it requires more space than lubuntu. I also did a test with a 120gb ssd and I got the same error.
The usb live stick works and installs fine on other machines.

1 Like

Weird… At this point, I’m out of ideas. Fortunately, there are some pretty smart people here and maybe they’ll chime in.

Be patient as not everyone is here at the same time and folks here tend to have busy schedules. We’re not a very large forum with a ton of members. After a reasonable amount of time, you might want to try asking at AskUbuntu, there are more eyes there. Other than that, I’m out of suggestions.

1 Like

I think that your firmware blocks the attempts to add a new boot entry. Please enter your firmware settings and check, that operating systems can write into EFI variables.

I suggest to change one setting at a time and retry the installation.

If this does not help, please provide the complete input and output from the terminal:

sudo parted --list
sudo efibootmgr -v
3 Likes