Can't install Lubuntu 20.04 LTS

Downloaded Lubuntu 20.04 LTS 64bit version. The sha256 sum checked out ok. I flashed a USB drive and the file checker passed and said no errors. When I get to the desktop, I setup my wifi connection and that works. I then click on the Installer icon and go through each step. I get to the end and click the Install button, then it asks if I’m sure and I click the Install button again. The installer window then pauses for a second and then just closes out without installing anything. I’ve tried repeatedly and it always closes out and refuses to install Lubuntu. I picked to erase disk in the installer and the drive to install to is not mounted, I checked with KDE Partition Manager to make sure it’s unmounted.

I’m stuck now, anyone had this happen before?
System is:
AMD Athlon 64 3200+ 2.2GHz
ATI Radeon Xpress 200
100GB Hard drive 1st drive
80GB Hard drive 2nd drive
1.5GB Ram

Neither hard drive is mounted and the installer will not install to either drive. Both drives are partitioned and ready to go.

I would always jump to terminal and check for errors with installation media (sudo dmesg |grep squashfs) firstly. Even though you had a pass, errors can still occur on cheap consumable flash media (built to cost, not reliability).

Next as calamares crashed (installer closed) I would expect a .crash file in /var/crash/ that may provide some clues. The top of the file is pretty readable, but most of it is developer intended so it won’t all be understandable, but still often provides clues.

Next I’d probably reboot (I’ve had issues with calamares after a crash of the program, so I restart the live session before re-starting unless I know the cause and know it’ll be fine without session restart) and start the installer using the following

  • open a terminal (ctrl+alt+T)
  • sudo -E calamares -d

the -d tells calamares to run with debug output, meaning it’ll provide more output as it runs. For some reason I’ve found it’ll work sometimes with this set, but even if it doesn’t work…

If it fails again, I’d file a bug report with ubuntu-bug calamares and follow the prompts. The -d means we’ll get more useful (mostly lengthy) output and have more chance to see the issue.

For help on filing bugs I’ll provide https://phab.lubuntu.me/w/bugs/

Which version did you try and install? You didn’t say if Lubuntu 20.04 LTS?, Lubuntu 20.04.1 LTS? or the latest Lubuntu 20.04.2 LTS? All are amd64 (64-bit), though if you need to file a bug we’ll get all details anyway.

2 Likes

@lonegunmen
You say that had erased the disk … all partitions was removed ? is using MBR or GPT ?
test the disks using HDAT (test and fix bad sectors) and try burn and DVD using the ISO.
have tried Lubuntu 21.04 hirsute ?

@guiverc
perhaps not is problem with files on usb drive.

I booted into Safe Graphics mode, the resolution was 800x600 I think and looked a bit blurry but the installer worked normally. Maybe a bug between the radeon video drivers and the installer? This was the only way the installer would work. So it’s finally installed but now I have another problem. It boots to a black screen with a mouse pointer. It appears like the radeon drivers aren’t working correctly? If I boot the hard drive using nomodeset, then I get the login screen but it’s in a lower resolution of 1400x1050 instead of 1920x1080. So far, I’ve not found any way to fix this black screen problem and there aren’t anymore hardware drivers to install. Any suggestions?

@lonegunmen
the system not has Radeon drivers for your video card.
I has a computer with radeon hd 3650 also without video drivers and low resolution.
In moment I not has any information how to install radeon drivers for Lubuntu 20.04.