Can't find Windows to remove from bootloader after installing 20.04.1

How do I find Windows remnant to remove it from bootloader? Thank you.

If it’s grub that’s offering to boot to Windows, you can easily remove the offending entry with grub-customizer.

FYI:anp@dan-surfacego:~$ /
bash: /: Is a directory
danp@dan-surfacego:~$ cd /
danp@dan-surfacego:/$ sudo efibootmgr
[sudo] password for danp:
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0000,2001,2002
Boot0000* Linpus lite
Boot0002* ubuntu
Boot2001* EFI USB Device
Boot2002* EFI Network

Thank you for you quick reply; is grub-customizer available in my lubuntu install? My problems began when I had to install 20.04.1 from Win10.

I just loaded up my 20.04 VM and entered:

apt-cache search grub-customizer

It’s in the default repositories. You can install it with:

sudo apt install grub-customizer

Once loaded, it’s fairly straightforward to use it. If you need help figuring it out, a search engine would probably be faster than me typing out responses.

Under list configuration just highlight the Windows entry and remove it. Don’t forget to hit the save button. That should take care of it.

3 Likes

Thank you; I’ll give that a try.

Be sure to let us know if it works. If it doesn’t, someone more adept than I am will likely step in and offer you an alternative solution. Like most things Linux, there’s more than one way to skin a cat. You could even do this with a text editor in the terminal, but the handy GUI method is the easiest (in my opinion).

Thanks again; I’ll let you know if it works.

Hello again,
What is meant by the following:

danp@dan-surfacego:~$ grub-customizer
localuser:root being added to access control list
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
   * Loading Framebuffer resolutions (background process)
   * Finding out if this is a live CD
 *** initializing (w/ specified bootloader type)…
   * Checking if the config directory is clean
 *** loading configuration
 *** loading - preserveConfig: no
   * unsetting saved config
 *** loading settings
 *** loading grub list
   * loading scripts…
   * loading proxies…
   * cleaning up proxy configuration…
   * creating proxifiedScript links & chmodding other files…
   * running grub-mkconfig

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.400: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
                                                                                                                                                                                 
(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.401: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed                                               
                                                                                                                                                                                 
(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.401: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed                                               
                                                                                                                                                                                 
(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.401: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed                                               
                                                                                                                                                                                 
(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.401: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed                                               
                                                                                                                                                                                 
(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.401: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed                                               
                                                                                                                                                                                 
(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.401: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed                                               
                                                                                                                                                                                 
(grub-customizer:1716): GLib-GIO-CRITICAL **: 22:25:01.401: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
   * restoring grub configuration
   * removing invalid proxies from list
   * loading completed
 *** grub list completely loaded
 *** loading saved grub list

followed by a popup for grub customizer that I can’t copy & paste; is this what I’m supposed to save?

I have options to save & install to MBR.

I’m not actually sure. Maybe someone will jump in and explain what’s going on.

I too just tried it - opening it from the terminal 'cause it seems it doesn’t want to open any other way on 20.04 and I was at least able to remove an entry and I was able to customize boot by removing the quiet splash. It did throw a bunch of those sort of errors - but the changes did take. (I just rebooted to ensure they did indeed take.)

I’m pretty sure this is a bug that I didn’t know existed until now. That’s not how it should work.

Let’s see what folks add to this and one of us can file a bug against the package to see how this all shakes out.

How can I install a new distro to clean up this mess when I can’t boot from the USB device? Thanks.

FYI: current boot device order:

  1. USB storage
  2. Internal storage
  3. network boot-IPV6
  4. network boot-IPV4
  5. Windows boot manager

Before taking such drastic steps, you can remove Windows from the grub boot menu with a text editor - it just means getting your hands a little dirty. I’m assuming you’ve done all the basics like sudo update-grub. So, look here:

As you probably don’t have gedit, I’d change

sudo gedit /etc/default/grub

to

sudo nano /etc/default/grub

The answer should otherwise work.

If you can’t boot from a USB, I’d first ask why. Are you writing the USB properly with something like Balena Etcher? There’s a member here @guiverc that has a neat way of installing Linux without a USB, so I’ll ping them.

Thank you; I’ll give that a try. The reason that I posed the question in this way is that I had to install 20.04.1 by going thru Windows to recognize the USB device initially. When I boot now, the 1st screen that I get is the Win symbol, then a pause, and the Win screen again before 20.04.1 loads. I’m concerned that MS would prevent me from installing future distros if I don’t solve this problem.

Well, I’m confused; this is the result of sudo nano /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="0"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

And this is the contents of my boot dir:

danp@dan-surfacego:/boot$ ls
config-5.4.0-42-generic  grub                         initrd.img-5.4.0-65-generic  memtest86+.elf               System.map-5.4.0-65-generic  vmlinuz-5.4.0-65-generic
config-5.4.0-65-generic  initrd.img                   initrd.img.old               memtest86+_multiboot.bin     vmlinuz                      vmlinuz.old
efi                      initrd.img-5.4.0-42-generic  memtest86+.bin               System.map-5.4.0-42-generic  vmlinuz-5.4.0-42-generic

I don’t see how to remove Windows from grub. Help! Thank you.

Me too!

Is this bootloader that you’re having issues with generated by Windows and not grub? If so, I know not a darned thing about Windows.

Your grub doesn’t show any remnants of Windows, nor is it probing for OSes.

It appears that Windows is controlling the boot process:

Is there any other info that I can provide to help you figure this out? Thank you.

That has to be a Windows bootloader. It has to be.

Hopefully someone else will chime in at this point. I know next to nothing about Windows.

If it were me, I’d backup my data and then reinstall - but I’d wipe every single partition out, deleting them all and making one single partition and then adding a new efi partition if that’s what’s needed. That seems rather brutal for something that has to be easier than that.

I think a couple of fellow users mentioned something about using Windows for work, so maybe they’ll chime in. I hope so, 'cause I don’t.

The grub file that is what you see when you boot is found at /boot/grub/grub.cfg

It’s here you can remove the Windows entry, and not have it appear when you next boot, however that file is re-created whenever update-grub is run, and it’s files in /etc/ that are used in it’s creation.

A quick scan of a windows system of my own

I find no reference to “Windows” in my /etc/ folder, outside of the search scripts (/etc/grub.d/30_os_prober, you can see Grub2/Setup - Community Help Wiki for details of that, but I see nothing specific to what’s on my box; only the search script)

However the only windows system I have is XP (my later versions were either deleted, or the HDD failed & the unused windows wasn’t replaced)

Suggestion - update-grub

I would firstly re-create your grub file, via the command update-grub then scan to see if the windows is still there (if you haven’t re-created that file via that command, or an updated-kernel causing it to run, it’ll still show links to removed partition(s)).

As update-grub runs, it will report what it finds to the terminal. You can always grep or view the created file post-completion too.

If it’s still there after the update-grub, all I can suggest is to manually edit the /boot/grub/grub.cfg but I’d hope the update-grub would cause it to disappear. If it’s still there, I’d likely explore using KDE Partition Manager looking for something that causes windows to be detected next.

FYI: I have insufficient experience with grub-customizer, and don’t have it installed on any system, so my comments ignore that details. I can’t recall where it writes it’s configs, but I’d likely fgrep -r and search for part of the string you see… It’s what I did on a system here with the windows XP as I wrote this response.