Boot up time very slow L.18.04 64bits

i have tried many of linux program. Linux mint with 32 bits pc and 1 gb ram. Its work but it can hang/stop. And lubuntu and now i using Linux lxle 16.04 -32 bits. Its working good. I installed linux lxle 16.04 -64 bits on a other pc. It have 2 gb ram. It work good- but when i updated it -i lost my wifi connection. Now i have installed Lubuntu 18.04 -64 bits on that pc with 2gb ram. It work but the startup time its very slow. I have looked in internet after to solve this. The startup work good with lxle on this pc- but with lubuntu its to slow. Lubuntu work good when it have done the startup- but it take to long time. It come with some error flipe time out -if i remember i get this error in the black startup -atomic-helper-wait-for-flip-error

I uset this i found in an other post.

Edit the file /etc/default/grub: VISUAL=leafpad sudoedit /etc/default/grub

Replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

Save and close the editor

Update your Grub configuration: sudo update-grub

Reboot

the startup went better with this. Now it take 75 s from i start to i can use lubuntu. The atomic help flip error get away. thank to apt -get who postet that . If any know about any other thing 1 can do to get start up quicker - i thank for all help.

i have also done this - redused to 10.
Lubuntu’s inclination to use the swap, is determined by a setting called swappiness. The lower the setting number, the longer it takes before Lubuntu starts using the swap. On a scale of 0-100, the default setting is 60. Which is much too high for normal desktop use, and only fit for servers.

i have only 2gb ram. If you have 8 gb and mybe 4 gb ram you dont need to do anything with this.

Personally I think it’s wrong to compare the boot times of different systems unless they contain the same software-stack (inc. versions) and do the same thing.

I wrote a response for this days ago, and actually timed Lubuntu 18.04 LTS on a thinkpad t42 (single core pentium m, 1.5gb ram) starting after ‘grub’ till login screen (pause as I enter password), then to when desktop is displayed, and finally is fully loaded (ie. all disk activity ceases). The times I no longer have but at over a minute (~75 secs) - I don’t consider it a problem as you only boot a system once a session.

I also compared times with a x86_64 thinkpad sl510 (c2d-t6570, 2gb ram) which did take longer (which I didn’t expect, and I don’t know why) but again not that much longer that it worries me.

But turning the system on isn’t something we do many times a day; usually once. I also turn the system on before I sit down, and am usually more interested in the drink or other things than getting to work straight away anyway, so I don’t consider it wasted time (even without a drink, I’m commonly considering what I need to do, planning my session before I actually start).

Ubuntu has snaps enabled - this allows greater functionality which yes has the cost of a longer boot time, but allows us to run in an older system (eg. a LTS release) newer apps and in a confined or more secure environment, than exists if we limit ourselves to debian packaging. We still have choice (we can use debian packaging for most apps, or use classic/less-confined security models too with our snaps). Other distros can be faster by disabling/not-having snap functionionality, but they lose choice & the security models available with snaps. It’s a choice, and Ubuntu has chosen to use snaps and does favor security.

If you want help with your -atomic-helper issue; you’ll need to be specific with when it occurs, where you see it and be exact with text.

2 Likes

Lubuntu to my knowledge doesn’t touch the kernel setting of swappiness. As I don’t only use Lubuntu, I had a quick look (ssh) around CentOS, Fedora, opensuse, and debian systems and was not surprised that all have the same setting of 60. (I did pick systems that I’d not changed; I do reduce the value on systems which have swap partitions on ssd).

60 is the default for the linux kernel, as overall it’s the best value for general use. We have the choice to change it (it’s GNU/Linux after all so choice is our right), so we can change it to suit our needs, our machine’s memory - which yes will differ, and the ‘best’ for most cases won’t always suit our use-case, but either way it’s not Lubuntu specific.

https://www.kernel.org/doc/Documentation/sysctl/vm.txt

swappiness

This control is used to define how aggressive the kernel will swap memory pages. Higher values will increase aggressiveness, lower values decrease the amount of swap. A value of 0 instructs the kernel not to initiate swap until the amount of free and file-backed pages is less than the high water mark in a zone.

The default value is 60.

i got atomic helper issue away with this i wrot up her.