Boot issue Lubuntu

Hello,
after perfect installation the system can’t reboot from the hard disk, only on live DVD.
Could you tell me how to fix it ?
Thanks
Rgrds
rood

lubuntu@lubuntu:~$ sudo parted --list
Model: ATA TOSHIBA MK5065GS (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 500GB 500GB primary ext4

Model: Unknown (unknown)
Disk /dev/zram3: 489MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number Start End Size File system Flags
1 0.00B 489MB 489MB linux-swap(v1)

Model: Unknown (unknown)
Disk /dev/zram1: 489MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number Start End Size File system Flags
1 0.00B 489MB 489MB linux-swap(v1)

Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Model: TSSTcorp CDDVDW TS-L633C (scsi)
Disk /dev/sr0: 1681MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac
Disk Flags:

Number Start End Size File system Name Flags
1 2048B 6143B 4096B Apple
2 1668MB 1672MB 4063kB EFI

Model: Unknown (unknown)
Disk /dev/zram2: 489MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number Start End Size File system Flags
1 0.00B 489MB 489MB linux-swap(v1)

Model: Unknown (unknown)
Disk /dev/zram0: 489MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number Start End Size File system Flags
1 0.00B 489MB 489MB linux-swap(v1)

lubuntu@lubuntu:~$ sudo efibootmgr -v
sudo: efibootmgr: command not found
lubuntu@lubuntu:~$

Start the system from DVD, open a terminal and execute:

sudo mount /dev/sdb1 /mnt
sudo mount -o bind /dev /mnt/dev 
sudo mount -o bind /sys /mnt/sys
sudo mount -t proc /proc /mnt/proc
sudo cp /proc/mounts /mnt/etc/mtab
sudo chroot /mnt /bin/bash
grub-install /dev/sdb
exit
sudo umount /mnt
reboot

reboot failed again

sudo umount /mnt - gave a message similar to “device already worling”. I’ll try again

Thanks

To run a command as administrator (user “root”), use "sudo ".
See “man sudo_root” for details.

lubuntu@lubuntu:~$ sudo mount /dev/sdb1 /mnt
lubuntu@lubuntu:~$ sudo mount -o bind /dev /mnt/dev
lubuntu@lubuntu:~$ sudo mount -o bind /sys /mnt/sys
lubuntu@lubuntu:~$ sudo mount -t proc /proc /mnt/proc
lubuntu@lubuntu:~$ sudo cp /proc/mounts /mnt/etc/mtab
cp: ‘/proc/mounts’ and ‘/mnt/etc/mtab’ are the same file
lubuntu@lubuntu:~$ sudo chroot /mnt /bin/bash
root@lubuntu:/# grub-install /dev/sdb
Installing for i386-pc platform.
Installation finished. No error reported.
root@lubuntu:/# exit
exit
lubuntu@lubuntu:~$ sudo umount /mnt
umount: /mnt: target is busy.
lubuntu@lubuntu:~$

Just reboot. It should work.

If not, then you have to check the settings in your BIOS/UEFI.

it doesn’t work.
ok, I’ll check but I have no idea about what is going wrong in the BIOS
Anyway, thank you very much for you assistance

Check, that the hard drive with Lubuntu is the first in the boot order.

And check, that UEFI is disabled (or CSM/BIOS Legacy is enabled).

hard drive starts with Toshiba and fail.
I don’t succeed to get in UEFI probably because I erase Windows
keep on trying anyway
thanks

Hello,
How’s life? Hope well.
I tried but can’t access to UEFI.
The hard drive says Toshiba and not Lubuntu, weird I believe.
Do you have any clue to solve the issue, otherwise I go further.
What other linux install do you advice?
Thank and have a nice day

What does that mean? An error message appears?

That’s not good. You always should be able to access the UEFI.

No, that is pretty normal. The firmware doesn’t know, which operating system is installed. The firmware knows about the hardware and (normally) where to find the bootloader(s).

As a first step, you should try to enter the firmware setup to change and check the settings. Make a research, maybe also others with the same hardware have the same problem and a solution.

Lubuntu seems to be installed correctly in BIOS mode.
If your firmware expects the bootloader in EFI format, then it cannot boot. In this case, either you disable EFI mode in the firmware settings or you install Lubuntu in EFI mode. To do this, you need to boot the installer in EFI mode.
In some UEFIs, when you select another boot medium, the installer might be listed twice. One entry is for UEFI and the other is for the BIOS mode.

I searched but I couldn’t find anything concerning such a problem.
Anyway, I decided to install Ubuntu instead and it worked perfectly. The booting process didn’t fail. I am happy with that. Now, I can enjoy an open source OS.
Then, I believe there was an incompatibility of my laptop environment to Lubuntu.
I don’t think if you should investigate further but anyway I raised the issue.
I wish you good work and stay safe.
thanks
rood.

Good day all,
Just to share:
Having the same issue “No Bootable device” after successful installation.
Acer ES1 notebook BIOS does not come with options to select UEFI or Legacy.

(It’s late now, will try to install Xubuntu tomorrow)

@zuixian
How do you know, that it is the same problem?

And some Acer devices are special. You have to manually add the bootloader as “trusted for executing”. If you need more help, please open your own thread.

thank you apt-ghetto,

Managed to solve the Lubuntu boot issue on Acer ES1-432.
(renamed grubx64.efi to BOOTX64.efi, and placed into dev/sda1/EFI/Linux)
Will share the steps in a new thread.
Cheers

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.