Balena Etcher doesn't start up

I downloaded BalenaEtcher from balenaEtcher - Flash OS images to SD cards & USB drives but the appimage doesn’t start on Lubuntu 24.04… When I double click on it nothing happens. Any help?

Did you make the AppImage file executable first, as the AppImage documentation describes?

1 Like

Yes of course I did. Also on right click I checked “Trust this executable”

And still nothing happens, the appimage doesn’t launch. Also at first it wanted to open it with the LXQT Archive manager, I changed it to Featherpad, and still nothing…

Good, now there’s the other part: you have to satisfy AppImages’ dependencies. Run it in the terminal and you’ll see the problem.

1 Like

Can you tell me the command I need to run in the terminal?

  1. Open pcmanfm-qt to the appropriate folder (probably ~/Downloads)
  2. Click Tools → Open Terminal (or F4)
  3. Type ./b then hit Tab until the balena filename appears¹
  4. Hit enter
  5. Read the result and follow the instructions

¹ just FYI . is a reference to the current directory; you can’t run any command without specifying its full path unless it’s actually in your $PATH

1 Like

Got it, it is FUSE that is missing, how do I install it?

Simply sudo apt install libfuse.so.2 ??

1 Like

Like I said, follow the instructions, particularly the very last sentence and the link included.

You can Ctrl-Click on it to open it in the default browser.

1 Like

I followed the instructions on the github link, installed libfuse and the appimage still doesn’t work…

These were the commands:

sudo add-apt-repository universe

sudo apt install libfuse2

I got this right now, what do I do?

1 Like

Interesting. Using the same version of everything, I get a different result.

If yours is to be believed, you simply need to do the following:

sudo chown root:root /tmp/mount_balenain7tsT/usr/lib/balena-etcher/chrome-sandbox
sudo chmod 4755 /tmp/mount_balenain7tsT/usr/lib/balena-etcher/chrome-sandbox
1 Like

Still doesn’t work…

1 Like

Best to check with Balena. Here’s someone having the same issue. You can run it with --no-sandbox and it will work but that kind of goes against one of the points of AppImages.

1 Like

Never mind, thanks for your help though. I will use my Linux Mint computer when I need BalenaEtcher. Linux Mint doesn’t have these issues that Lubuntu does, I just use Lubuntu on this PC because it is a very old (17 years old) laptop and Lubuntu is more stable on this PC than Linux Mint. So Lubuntu helps this computer to survive hahah But Lubuntu LXQT needs some serious bug fixes, since the install I encountered around 10 different issues, and as mentioned earlier I never had any such compatibility problems on Linux Mint.

It’s interesting, the Viber appimage does work, the Viber .deb installer doesn’t work.

Yep, like I said, it’s a Balena issue. Just goes to show that so called universal packages aren’t exactly universal.

2 Likes

An alternative that is tested with the current versions of Lubuntu (and the other Ubuntu community flavours as well as Linux Mint) is mkusb.

It can create live (live-only) USB boot drives by cloning (the same method as Balena Etcher is using), and also by some other methods. mkusb can also create persistent live drives.

4 Likes

You should be able to download gnome-multi-writer and or usb-creator from the repository’s and use them which is what I do.

I’ve also had problems getting App images to work.

I believe that Ubuntu doesn’t allow App images to work anymore because they are all about using Snaps.

Don’t get me wrong or start throwing rocks I like Snaps and have no problems with them.

Just my 25 cents worth.

1 Like

Found the solution to run Balena Etcher on Lubuntu 24.04, I just have to type the following command, unfortunately it has to be typed each time after reboot:

sudo sysctl -w kernel.apparmor_restrict_unprivileged_userns=0
3 Likes