B43 firmware error: can I go ahead with Lubuntu 20.04 install?

I put the new 20.04 iso on a USB stick. I have booted and shut down from the USB stick several times. Each time, I get a new message when I’m shutting down. Last time, it was three lines starting with…

[ 97.605515] b43-phy0 ERROR: Firmware file “b43/ucode15.fw” not found.

I remember going through a b43 firmware problem on a version of Lubuntu several versions back. I believe this is a Broadcom Wi-Fi issue.

I have a Dell Inspiron 1545 laptop that came with Ubuntu pre-installed. The first time I upgraded the OS, I lost Wi-Fi and had to install some files. Then the second time I upgraded the OS, I was told in a forum that the Broadcom issues were fixed and the b43 installer didn’t need to be added in the future. (And indeed, on that OS installation, Lubuntu worked “out of the box”.)

I am wondering if I can go ahead an install Lubuntu 20.04…

I found my old USB dongle with the b43 zip file and command line instructions I used before for installing the files. I can do that exact thing again, but if anything has changed and I lose Wi-Fi, I am screwed.

So, did the previous Broadcom issue return? Or am I getting this message simply because I am booting from a USB (I have never done that before)?

If it sounds like I know what I’m talking about, I don’t. So please help.

Broadcom sucks and always will, but that also means that it will suck in the same way, so the same solution will fix the problem.

That’s true. It worked.

For anyone having the same problem with Broadcom, I was able to install Lubuntu 20.04. I did not have Wi-Fi afterwards. I had to use the method described in the following posts to get Wi-Fi working, but it did work.

https://ubuntuforums.org/showthread.php?t=2316978

https://ubuntuforums.org/showthread.php?t=2098717&p=12426843#post12426843

Please note that if you don’t have an ethernet cable, you have to prepare to do this by putting everything on a USB before you install 20.04. I also put a PDF copy of the above instructions so I could remember them.

The canonical documentation for this process across a variety of Broadcom cards is on the Ubuntu Wiki.