Ark cannot handle compressed file with Chinese characters in Non-Unicode coding

Very often I need to extract compressed files with Chinese characters in either folder name of file name. If the source files are compressed in Unicode coding, I have no problem to extract them directly in PCManFM-QT. But if the source files are compressed with Non-Unicode coding, the Chinese characters will not show correctly after extracting.

Although I can use “unar -e cp936” in terminal to set correct coding page and get the files with correct Chinese characters, I am wondering if I can get PCManFM-QT/Ark work with this case. I haven’t find any options to set the coding page in PCManFM-QT/Ark.

Anyone could help?

Without an example, we probably can’t, no.

you can try this → encoding - How can I extract an RAR whose file names are non-Unicode in Linux? - Super User

Also try lxqt-archiver (in the development release, i.e. what will become Hirsute Hippo/21.04) as it will likely replace ark for that release.

However, an example would still be helpful.

I am wondering if I can get PCManFM-QT/Ark work with this case.

I’ll just toss this into the mix.

In PCManFM-Qt, you can change the integrated archiver. It’s in the preferences. So, if you can’t get it to work and have another piece of archiving software installed that does work you can change it.

Preferences_020

Hi,

I have tried to use a different archiving software as you suggested. But even after change, the file is always opened in ARK when I double click it.

Could you please provide an example file? Pretty please?

Hi,

Can I upload a file here? I haven’t find the way.

You can upload it to lots of places! There’s all sorts of file sharing services out there. Then just provide a link here.

Very good points.

Here is the link of the compressed file for test. https://1drv.ms/u/s!Aqo8XAUDbJtSgSRUpu1kWIgNLcqv?e=ejDi73

Hi

I upload several snapshots for your reference.

Wrong Chinese Characters shown in ARK

Wrong Chinese Characters in folder name after extracting
Wrong Chinese Characters in folder name after extracting

Correct Chinese Characters in folder name after extracting
Correct Chinese Characters in folder name after extracting

Ok, I can confirm this even in lxqt-archiver in Hirsute, which is likely the direction that we’re going to go for the future, so I need to file an upstream bug. Am I ok to share that example around?

I suspect if you install any of the other archivers mentioned and set up the archiver integration, they all work fine, right?

Thanks for the bug reporting. Pls feel free to share the example file.

If I remember correctly, I have installed only unar after the complete new installation of Lubuntu. I did try to set different archiver integration in PCManFM-Qt, but the zip files were always opened with ARK. Therefore I think I haven’t installed any other archivers mentioned in the integration drop-down list.

It would be helpful if you could test the other available archivers.

I have tried file-roller, xarchiver and engrampa. All have the same problem as ARK.

I haven’t tested lxqt-archiver, arqiver and squeeze, since I couldn’t find the package using apt search.