(20.04) Some fast launchers doesn't work or launch anything

At the moment of creating a fast launcher (dragging a file to the LXQT panel) of a file that is in a folder with spaces in her name (or that has strange symbols), the fast launcher doesn’t work.

I tried to go /home/cele/.config/lxqt/panel.conf and adding ’ to the route of the file and didn’t work. Tried adding " to the route of the file and didn’t work.
Also, if I update the panel entries (for example adding one more fast launcher) that ’ or " disappear.

I know that creating a .desktop file and dragging it to the panel would solve the problem, but is uncomfortable and could get mad a new user. Am I doing something wrong? Or LXQT doesn’t prevent this situation?

I don’t include system information because I think that is not a hardware/system problem?
I have Lubuntu 20.04 and it’s updated.

I tested it a bit and it seems creating a quicklauncher with a space anywhere in its path (doesn’t have to be the folder, spaces in filenames do it too) results in a nonfunctional quicklauncher.

Looks like a bug to me. I can’t find anything on this issue, so it could very well be a new bug. You can report it on lxqt’s github page.

I wrote here (github, lxqt-panel) one month ago a suggestion of a addition and had no reply. Do you suggest reporting here, or on another place?

Bug reports usually get much quicker replies than feature suggestions. I reported the bug here. It “feels” like the sort of issue that isn’t that hard to fix for the developers. (I could be wrong of course)

Oh, I asked that because I don’t reported a bug ever, you won me
Thanks, let’s see what they answer.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.