(20.04 live) Problems with recognizing umts-stick out of the box

Hello altogether,

I have a question regarding new Lubuntu focal fossa.

Presently I´m running Lubuntu 18.04.4 LTS, 64 bit as my main system. This one should receive updates until April next year. So basically I´m not in hurry to do a fresh install.
Nevertheless I like to try things out in advance as I´m not so pleased with surprises that pop up at an inconvenient time.

Therefore I decided to give Lubuntu focal fossa a try by creating a bootable usb-stick with ventoy (https://www.ventoy.net/en/index.html )
which by the way is a script to make a stick bootable for more than just one ISO. It seems to work just fine and I succeeded in booting the Lubuntu 20.04 ISO.

So I could try it out as a live system.

There´s one thing that struck me as odd though.

I ran into problems establishing an internet connection with my umts-stick. I never had any problems with that using my present system (bionic beaver).

The thing is: My umts-stick is my only means of connecting to the internet.
It´s an Aldi umts-stick and “lsusb” recognizes it that way:

Bus 001 Device 015: ID 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem

When running “lsusb” on focal fossa live the stick is listed. So no problem there.

The real problem lies in the usage of the network-manager symbol in the taskbar. Focal fossa now uses “nm-tray” and clicking on that my umts-stick doesn´t appear at all.

After configurating the parameters of the stick by adding a new connection it now appears in the popup menu but has a little “x” on the left side of it. It´s still not available.


As a workaround I tried the following: I typed my old command (“nm-applet”) as I know it from bionic beaver and a second symbol appeared in the taskbar.
And immediately - without any further ado - a popup appeared asking me for my PIN (referring to the umts-stick which all of a sudden is recognized).

After entering the PIN I could connect to my provider using my 4 weeks flatrate. Everything worked just fine now.

So basically what it comes down to is the following:

nm-tray” doesn´t work out of the box and I cannot get it to work.
The command “nm-applet” works fine. The stick is immediately recognized all by itself.

Can anyone give me some background information as to what´s going on?

Thanks a lot in advance.

Rosika :slightly_smiling_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.