20.04 installer not working in qemu VM

I’m trying to install 20.04 on a VM:

$ qemu-system-x86_64 -hda disk.qcow -enable-kvm -net nic -net user -cdrom lubuntu-20.04-desktop-amd64.iso

The GRUB menus come up but then the VM fails to boot, very quickly just crashing out with “Physical KASLR disabled: no suitable memory region” and apparently stalling. Anyone got this working?

Tested on a box running Lubuntu 20.04.
I installed from lubuntu-20.04-desktop-amd64.iso in a VM with Virtual Machine Manager with no problems.Booting no problem and runs well. Have also installed in VirtualBox with no problems either.

Hmm. I was running qemu on a box with Lubuntu 19.04. Seems like it shouldn’t matter what the host is. You weren’t using qemu, if I understood correctly? Maybe that’s a hint what the problem is?

I can reproduce this with

qemu-system-x86_64 -enable-kvm -net nic -net user \
-cdrom focal-desktop-amd64.iso

According to the documentation, the RAM is set to 128 MiB, which is not enough for a desktop system like Lubuntu.

If you specify the RAM size, the installation image will boot:

qemu-system-x86_64 -m 2048 -enable-kvm -net nic -net user \
-cdrom focal-desktop-amd64.iso

From my experience, you should give at least 700 MiB RAM to the machine and the installer should start.
For the installed system, you can try to lower the RAM.


Brilliant. Thank you. I thought the default was 2048. When I used “-m 2048” it worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.