20.04 Boot hangs on iMac

Hello! I’m a NEWBIE here, so patience please.

Config is a late-2009 iMac, 2.93GHz Core 2 Duo, 8GB RAM, 200GB partition of a 640GB HD

I downloaded, verified checksum, and ran the thumbdrive Lubuntu 20.04 successfully yesterday, so proceeded to partition the physical 640GB HD, cleaving off 200GB for Lubuntu LTS install. Then installed 20.04 LTS successfully, and installed all updates. Was also able to activate the WiFi driver and NVIDIA driver. Everything working marvelously . . . . FF browser, LibreOffice, accessories, etc.

I played around further this morning, no problems.

I then shutdown Lubuntu, booted back to my OSX El Capitan on the other partition to do a bit of work, and then shut down OSX and rebooted Lubuntu and THAT is where it HANGS . . . .with the white Lubuntu logo and five dots below on black screen. It moved quickly through the the five dots (~5 sec) and then stalls on the second pass with 2 white dots lit white and the remaining three blue.

After about an hour I decided to reboot – same result. I’m not sure how to boot into a “safe mode” (or some such thing) but I was easily able to boot the thumbdrive and readily see the two HD partitions from the file manager.

It would seem to me that some the HD boot image has been corrupted, BUT that’s just a guess.

Being NEW here, can some please provide me some basic guidance on where to turn?

Thank you so much . . . . really looking forward to making Lubuntu a viable solution for this aging but yet very capable piece of hardware!

When the the boot stalls at the Lubuntu logo, can you hit the ↓ key or the esc key from your keyboard to see if any text pops up on the screen?

If you can share a screenshot of the text that appears on the screen, we can probably give some tips on where to move from here.

Before getting to the logo while booting, please also try pressing the esc key to see if you can get into the grub menu and see if you can boot with an earlier Linux kernel entry. This will be presented to you as a list.You can just use the arrow keys to select/highlight your selection and hit enter to boot with the kernel you want. Usually the latest and default one will be the one with the higher number… you can try the one before the latest on the list.

Hello That_Random_Guy . . .Thank you for your reply.

I tried both, with no luck. The keyboard is essentially dead once the logo is presented, and hitting either the down-arrow or esc key gets no response.

Also did the same with trying to intercept the boot process. It’s a bit tricky on the Mac. . . . first have to get through the Mac boot loader first (shows three options, OSX, OSX-Recovery, and EFI–the Lubuntu partition). Once I select the EFI partition, I get a lonely little white hyphen on the black screen . . . with the ESC button was pressed, it went absolutely nowhere. Then I rebooted but held off on the ESC button UNTIL I saw the Lubuntu logo. When the ESC button is pressed then, I get an absolute flurry of text scrolling by, far too fast to read.

As an aside, prior to your initial response, I booted the thumbdrive Lubuntu and did an file system check on the partition, and all APPEARED to check out just fine. I did so twice, first with terminal fsck command and then later with the KDE partition manager. No luck.

Not sure where to turn next.

Let’s try this part again and let the text run through boot until it stops. Normally, when there’s a problem at boot, it will stop after a certain point it can’t pass. If you can send us a screenshot for the wall of text that shows up on screen once it’s stopped moving/scrolling, maybe we can see what’s causing the glitch.

1 Like

Hello TRG,

Okay, I tried again as suggested. . . .thing is though, if ESC key is pressed, the “wall of text” continues to stream through, endlessly. Some time after I lay off the ESC key, the text dump stops and I’m left with a black screen – going nowhere.

So clearly there’s no static screenshot I can provide, so did something else: I took a 2-second slo-mo video of the screen and I am posting a handful of images here. Hopefully this will provide some insight!

Uploading: Screen Shot 2022-04-02 at 3.21.14 PM.png…

That’s pretty interesting… I was expecting it to stop at some point with an error. :face_with_raised_eyebrow:

I’ll see if I can find something to figure out how to bring up grub for your mac. I would still try and test out to see if booting an older kernel helps at all. For that, we need to get to the grub menu during boot… on regular PCs this is usually done by pressing either esc or shift depending on if EFI is used/present. I haven’t used Macs before unfortunately.

It’s kind of weird and suspicious how this all happened after updates were applied but I’m also not sure how Macs work entirely.

If I can find anything, I’ll post it here.

Thanks TRG . . . I’ll hang in here for another day, but if we’re coming up dry I may just re-install 20.04 LTS and see if this re-occurs.

As another thought, is there anything that can be determined by inspecting the install from the Live USB? THIS seems to be quite stable, though of course not an end solution.

You will technically be able to access the Lubuntu system by mounting the relevant partition under /mnt when you’re using the live USB. I don’t think this will work if you chose to encrypt your Lubuntu install.

You can maybe look around in /var/log and maybe see if /var/log/syslog has anything there.

Please make sure that you’re actually looking at the mounted file system that’s actually on the iMac and not the contents of what’s loaded from the live USB. In the example of using /mnt as the mount point for the installed Lubuntu system partition, the aforementioned log files would actually wind up being at /mnt/var/log/.

Please also note that Ubuntu has their own forum which may get other eyes/input for your problem.

1 Like

Good idea, TRG . . . appears to be lots of good stuff in the logs, but will need someone knowledgeable like yourself to interpret. It would APPEAR that the boot process advanced significantly, but for whatever reason does not want to present the login screen. Attaching a screenshots as it appears I can NOT attach other file types, eg. TXT files. So here goes . . . first provides directory view ie, Lay-of-the-Land, second and third are first to screens after boot, and the remainder are the final screens of text in the syslog.

You can always just copy/past the text from the file and post the contents here.

If the post won’t go through due to going beyond the character limit, you can always post it to pastebin.com and share the link to the post on that site here.

From looking at the screenshots, I see that the fsck didn’t mention anything but I’m not familiar with what it actually checks for when booting. I don’t think that’s related to your problem though. I will need to look at it some more.

Incidentally, there is one more thing I would like to test to see if it works at all since the contents of what you’ve uploaded so far makes me think there’s possibly just some driver issue causing this behavior.

Please try booting Lubuntu from your iMac again and when the screen gets to the point where it’s just black and no more text appears on screen, please try the following key combination on your keyboard:


If nothing still happens, try doing the same key combination with F5 or F6 keys instead of F3.

If by some miracle that still produces no result, try this key combination:

Fn Ctrl-Opt-F3

This will tell Lubuntu to switch to a different console which usually let’s you login via command line as if you were using Lubuntu without the GUI. If the above key combination succeeds, you should notice a login prompt (no fancy GUI) where you can try logging in.

If that works, my suspicion leads to driver conflict but I would need more proof.

Okay, tried the Ctrl+Alt+F3 sequence, along with F5 & F6 variants too, with no success. (There is no Fn key on the iMac keyboard so set aside.)

Essentially nothing different. One thing I did try was to hit ESC upon seeing the Lubuntu logo and then Ctrl+Alt+F3 . . . . it slows down the wall of text for a bit but then continues on to a black screen.

Ugh!! I was thinking about the driver conflicts too, since the Live USB seems pretty solid, without additional drivers. QUESTION: is there a way to “neuter” the drivers (video & WiFi) in the installed system from the Live USB without re-installing 20.04 from scratch? Because that’s my sense of what the next step might be!

Thanks for your interest and support, TRG.

I still want to look at the logs some more but to answer your question quickly, I think this can be done with setting the nomodeset option during boot as mentioned here:

Unfortunately, I am sure this won’t work without some fancy commands to change the live session into using the installed system via chroot. I am not so sure how to do that and the only other way would be to have either access to the grub menu during boot or boot normally and change/update the grub defaults until the problem can be fixed and later restoring the defaults.

Since grub can’t be accessed and booting doesn’t finish cleanly, I can’t really think of much else right now.

1 Like

Interesting . . . Came across something similar here below:

I’m looking at the etc/default/grub file on my 20.04 right now . . . Looks like I could edit it, BUT how to update the DISK-based grub and not the USBLive is the question, pretty much as what you’ve noted. Looks like it may be possible, but would require a mere mortal like me to jump through a dozen or two hoops.

Re-installing from scratch looks much simpler, and probably less error-prone. I’ll press pause for 24 hours to see if any other ideas emerge.

1 Like

Here’s another . . . very close “hit”:


Where are the NVIDIA driver code bits kept in 20.04 and can I simply expunge these elements and have Lubuntu boot up with the default video driver?

I’m not entirely sure but I don’t think deleting those files will let you boot without unfortunately.

I think there’s a config file that needs to be updated to actually get that working but I’m thinking it will require the same thing as before… you either need to actually boot into the installed system or via the live cd and use chroot to update the config files/remove nvidia drivers. I haven’t really done the latter before successfully on my own.

If you don’t want to wait, you can reinstall and see if that comes up like before and just avoid installing the nvidia drivers. You can also see if posting to Ubuntu’s forum gets any input as someone might be able to chime in there.

Thank you for your support and assistance on this one, TRG.

Given the time spent on this so far, I’ve decided to take the latter route, ie. re-install. Just completed the install, as well as the upgrade (It’s “upgrades” versus “updates”, am I right? Still used to the MS vernacular!)

I have refrained from adding any custom drivers, both video and wifi. Would like to do the latter (wifi) but will hold off for a few days to see how the “vanilla” install works out.

At any rate, all appears to be well for the moment, with one exception . . . .Firefox. It seems to hang periodically, and it also did the same in the LiveUSB. Not sure why, but doing a simple thing like resizing a window can --at times-- tie things up in knots. FF is at version 98.0.2. I’ll do some more searching around in the forums for this.

BEFORE I close this issue though, it seems to me to be a rather glaring gap that there is no “recovery boot” or “bare bones boot” capability for this . . . perhaps just a “mac” thing? or a “grub” thing? SOMEBODY SOMEWHERE should be able to advise definitively the means to boot in SAFE MODE or some such thing, and what process and keystrokes this entails.

During the boot process, press the SHIFT key. That should bring up the GRUB menu where you can pick advanced options - which will include being able to boot to a terminal with root access.

You have to time it right and you may need to press the shift key multiple times just to get it right. But, you want to start right after POST and before the OS loads.


Thanks for the suggestion, KGIII.

I gave this SHIFT idea a shot during the boot process . . . . no luck at all. Tried various approaches and timings, all with no luck.

I’m beginning to think there are some basic differences in the way Mac hardware boots up compared to regular PC hardware, perhaps it’s the EFI vs BIOS thing . . . don’t know, but for whatever reason I can’t seem to intercept GRUB on the Mac. I have 18.04 on a very old Compaq notebook and can easily intercept there.

The bottom line for this issue, opened as “20.04 Boot hangs on iMac” is that I’m fine with closing it. Lubuntu 20.04 works fine from Live USB in safe graphics mode. Same with Ubuntu 20.04. However, to boot from an installed version on the iMac HD I had to modify the GRUB startup config with “NOMODESET” as per the askubuntu item below:

It’s just a shame this can’t be done on-the-fly by intercepting GRUB at startup. Would have saved a lot of time and frustration.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.