20.04 Beta Bug: Screen goes gray and gets stuck after changing transparency/opacity settings after other changes

Totally new even to Linux (considering going with Lubuntu) as a whole here so sorry if this isn’t the right way to report things but here goes anyway:

CONTEXT OF BUG:

  • latest beta downloaded on April 9th 2020
  • wrote to USB and tested live session on laptop 1
  • in Session Settings, enabled and started Compton
  • in Window Effects, switched to GLX
  • logged out, logged back in
  • (at this point the desired effects of those effects have kicked in, namely no more screen tearing when scrolling in Firefox. However, there’s a tons of transparency in menus, windows, title bars etc, so I decide to try to change those)

THE BUG:

  • go back to Window Effects
  • change a few opacity numbers to 1.00 (forgot which ones exactly)
  • clicked Apply
  • screen goes gray, cursor is still movable but everything has vanished and everything is completely unresponsive
  • give it plenty of time but it’s still stuck
  • have to do a hard shutdown

RECREATING THE BUG:

  • tried the whole process several times again, doing everything as before but this time only changing one opacity number (the one for title bars)
  • same gray screen problem, requires hard shutdown
  • try changing the number only slightly rather than all the way
  • same gray screen problem, requires hard shutdown

  • at this point i think maybe it’s a problem with the laptop so i start testing on laptop 2
  • exact same bug

  • at this point i decide to install it on laptop 1 (a spare laptop) anyway, in case it’s a live session thing
  • install, then on the installed Lubuntu do all the same things
  • before I click Apply, I go Power Management and change some settings there so I don’t have to do a hard reset
  • I set the closing lid action to Suspend on AC and Shutdown on Battery
  • back to the opacity settings change, click Apply
  • same gray screen problem
  • close lid to suspend
  • open lid, but instead of waking to the login screen, it’s still stuck on the gray screen
  • switch to battery power then close lid, to shut down
  • switch computer back on again, login, the title bar opacity change I made has actually taken place at least
  • decide to change the others to my liking at the same time (menus, inactive windows - both set to 1.00)
  • click Apply
  • this time the screen doesn’t go gray, visually things stay the same (the windows, the bottom bar are still there)…but it’s unresponsive, frozen. Except the mouse can still move, but it can’t do anything because everything is unresponsive.
  • close lid to shut down again
  • switch back on, log in
  • things are the way I want now at least

So, at this point all the opacity changes I made have been made, so that’s good, I suppose I don’t have to fiddle about any more with opactiy any more. But clearly the frozen gray screens and then the frozen existing screens are problems. And they happened multiple times, on 2 different laptops and both as a live sessions and fully installed. I hope that’s enough info. I also hope you can fix it soon because with my small tweaks I really like the feel and simplicity of Lubuntu and might roll with this as my first (and maybe last?) Linux distro.

I get the same gray screen, when I change Special Effect Settings from Xrender to GLX. First time I even changed this settings.