19.10 Problems with wifi and nmtray

I am still using 18.10 but, with an LTS approaching, I installed 19.10 on a laptop to see how things are going. Generally, I must say it’s looking very good.

I had some difficulty connecting to wifi during the install. There is no obvious way for a new user to connect to a hidden SSID, as there is now no option for this in the systray menu.

I now have problems with nmtray. The left-click information is a bit of a visual mess and when you right-click and try to edit a connection, you are presented with a shell window. Reboot after that and you have no wifi. It took me hours to discover that this is a feature, not a bug. The stated purpose of Network Manager to seamlessly maintain a connection when possible, is apparently overridden by nmtray, which requires you to manually connect after every startup.

So my first question is: how do you restore automatic network connection? Ticking the “connect automatically” box in settings has no effect.

(BTW. I notice that wifi power control is on by default. My experience is that this will only cause problems.)

1 Like

I feel you. I experienced nm-tray a week or two ago. The text-based window (which is fine for me) was all jumbled in terms of what’s editable. Also, it saved a failed connection which caused me to think there was a driver error preventing me from connecting to wifi. (For some reason I had the idea to delete that wifi session. When I connected again, it worked.).

I don’t know about hidden networks, but there is a network config tool in the “settings” or “system” menu area. It’s more like what you’d expect.

IMO, nm tray should be removed from the distro. Better to let people dig into system (or settings, wherever it is). Nm-tray isn’t useable. it’s just eye candy.

I rarely use wifi, but test (QA-testing) using it if using a laptop. I have three networks I use in testing, all of which are hidden SSID & the way I connect I assume is identical to if it were not hidden. Using nm-tray I “Edit Connections” (https://manual.lubuntu.me/stable/3/3.1/3.1.5/nm-tray.html) and add an entry for the network I want to connect to. Once entered and back to “Add Edit Delete Quit” options I usually test my entry by clicking on the nm-tray network icon on the panel, if it connects I in the terminal window until I’m over “Quit” and hit enter.

I’ve not experienced it loosing connection at any point (outside of other reasons such as interference, my going out of range etc), nor had any added config being lost next time I use the box (unless I’m using ‘live’ media in QA-testing where that’s expected behavior)

I can’t help with auto-connection on startup sorry; as stated I rarely use laptops/wifi; though a boot-up of a 20.04 install did have “Automatically connect” enabled, my hidden wifi details were entered & wifi in range but it didn’t connect on login. :frowning:

If I come up with anything I’ll return.

Thanks, but you realize that’s not in development, right? That it’s a final release? :slight_smile:

“Edit Connections” seems like the obvious solution. Is there some reason why this doesn’t seem so obvious?

I never noticed any problems here. What do you see as problematic?

Yes and one I find, as was mentioned elsewhere, can yield an inaccurate display. If you maximize the terminal window, everything works fine. It’s just a little clunky.

As mentioned in this bug there is no native connection editor in nm-tray. While that is problematic, it is beneficial because it is otherwise simple and functional and based on Qt, so we’d like to keep it. Because of this, we added “Advanced Network Confguration,” i.e. nm-connection-editor. “Edit Connections” doesn’t go directly to it because of a problem we had but I think I may have a solution to that for 20.04 (and maybe we’ll SRU this to 19.10).

I did not have this problem (and I’ve got that annoying Broadcom BCM4313 14e4:4727 rev 01 wireless card that is just problematic all the way around, at least on the test machine). Also I know of nowhere that nm-tray (yes, the nm does stand for Network Manager) intends to usurp what Network Manager does.

That’s strange and I cannot say I’ve ever experienced that before. I would remove the connection and add it again. It should default to having it connect automatically.

This is most likely a default setting on your kernel module. That’s not something Lubuntu would set by default but it may be something that Ubuntu or Debian or perhaps even the kernel itself set by default. Either way, though your generality that it could be bad might be true, it might not be for your particular module.

You can do something like lspci -nnk | grep -A3 Network to see which kernel module you’re using. Then you can see the parameters available with the module with modinfo -p module.

On the machine I’m on right now I find:

power_save:enable WiFi power management (default: disable) (bool)

And there’s nothing in /etc/modprobe.d to suggest anything different, so it’s disabled for me.

If this is truly not the case for you, I’d investigate a little farther and if it does indeed seem like it’s problematic, I would report a bug against the kernel itself in Ubuntu and let the Kernel Team sort out whether or not it’s something that should be fixed upstream or not.

This is a minor problem which won’t affect most users, but it does lessen the chance of annoying dropouts if /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf is set to 2, rather than 3. As I say, it’s a minor thing.

According to apt-file, that comes from the network-manager package. It looks like it’s been there since 2017, too. Note this was based on a bug concerned about the amount of power consumed by Ubuntu. However, you could always file a bug against the package and try to suggest otherwise. I don’t think it wold be unreasonable.