18.04 Mac install help - ISO error "no mountable file systems"

Hello,
I’m new here and to Lubuntu.
I’m trying to install 18.04 onto my 32bit MacBook and I can’t get past a very basic first step.
I have downloaded the i386 ISO from the official site and successfully burned onto a DVD. The disc has been verified.
However, I am getting an error when I try to open the ISO; “no mountable file systems”
So I think that this problem is caused by my system being HFS+ and the ISO not being compatible. After some searching I disabled journaling on my Mac’s hard disk, this has had no effect.
I cannot find another version of the ISO that is specifically for HFS systems.
My aim is run Lunbuntu only on this computer so I have no need to partition and I can reformat my hard drive too, if that is what is needed.
Can anyone point me in the right direction, I am struggling to find another Topic that covers this issue.
Thanks,
Mike

Mac specs;

Model Name: MacBook
Model Identifier: MacBook4,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.1 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 800 MHz
Boot ROM Version: MB41.00C1.B00
SMC Version (system): 1.31f1
Serial Number (system): W884610J5HS
Hardware UUID: B63FE011-6935-54F2-9084-5415459469F5

I’d probably start by using 64 bit. You don’t need 32 and I’m not sure the Mac bootloader can handle it even though the processor can.

Also, I’d probably not bother with 18.04 since support for it ends in just a couple months.

Thanks for the reply.
I was under the impression that my MacBook doesn’t support a 64bit OS.
So I’ll try the 64bit Lubuntu and see what happens!
Thanks for your time.

I have little experience with GNU/Linux (Lubuntu etc) on Macs so can’t help there.

If you have another box, I’d try booting the DVD there, and using the “Try Lubuntu without installing” option.

If the DVD was burnt correctly, I’d expect the DVD to boot on any compatible box (be it apple, dell, hp, lenovo etc).

I’ll provide

as I wonder if maybe you wrote the ISO as a file to the DVD, and not the as a bootable device, but this is just a guess. If it boots on other devices, the burn will be partially proven.

FYI: When you mention verified the disc, do you mean the Ubuntu verification process, ie. Installation/CDIntegrityCheck - Community Help Wiki which meant it burnt and you used the “Check disc for defects” option, or just the burner’s verification process? (which isn’t enough)

Thanks for your help.
I’ve also downloaded Lubuntu 20.04 and I have the same problem.
Even if I try to open the ISO from the desktop I get the same error message.
This is unusual as it should mount in Finder, even if I don’t run it.
But I believe that I must be doing something stupid as a beginner, this can’t be a universal problem as other people would have come across it and I can’t find much about it online.

I can’t use the Ubuntu verification process as it asks me to download Hombrew and that is generating another error in Terminal;

homes-macbook:~ Home$ $ /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"
curl: (35) error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
-bash: $: command not found
homes-macbook:~ Home$ 

I think I need an IRL friend who has a Mac and Ubuntu…
Does anyone know of any Mac-specific Lubuntu help?

Just go download that install.sh file somewhere and then open terminal and cd to the location of the file and then run /bin/bash -c install.sh.

As for finding help, don’t look for Lubuntu-specific help. Your issue is far more general. Look at AskUbuntu or the Ubuntu forums.

1 Like

Not sure if this helps but I installed Lubuntu two weeks ago on Macbook 3,1. A1181 2007 White.

I can’t remember if I used 18.04 or 20.04. I’ve done a few laptops this past couple of weeks. It was a core duo 2 chip, which I think is a 64-bit chip, so 20.04 would have worked.

I used usb which I had created on my desktop using Ubuntu and either the generic startup disk creator or mkusb - they both work with Lubuntu iso in any case.

On booting the Mac you have to hold OPTION / ALT until boot manager appears and this should show your USB as EFI_Boot

After that the only issue I encountered was with the Broadcom Wifi, but that was easily fixed once installed with the proprietary driver found in additional drivers (used Wired LAN connection to download it though)

Anyway it worked this way so I think you have the same model or one revision later, you’d hope it would probably be the same process (fingers crossed). It’s not exactly an answer to your question, but hopefully a method that gets you up and running.

Pretty sure I used this page to get me off the ground: How to Boot Mac from USB | Mac Won't Boot from USB Troubleshooting

Update:

I got my hands on another Macbook 3, 1 this afternoon. It booted fine using 20.04.1 installer using steps described above. Does need Broadcom proprietary driver to get wifi working.

Spec. for comparison its the Intel Core Duo P7450 64bit. chip. According to lshw

1 Like