18.04 issues with screen res on old laptop

Hi All,

I’m new to linux and I require help with fixing some issues. The main one is my screen resolution.

The max res is 640x480 and I hae tried many different fixes and all hae failed. I’e copied what I tried to do late below.

james@ubuntu:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
640x480 73.00*
james@ubuntu:~$ cvt 1024 768

1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz

Modeline “1024x768_60.00” 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
james@ubuntu:~$ sudo xrandr --newmode “1024x768_60.00” 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default
james@ubuntu:~$ sudo xrandr --addmode Screen 0 “1024x768_60.00”
xrandr: unrecognized option ‘1024x768_60.00’
Try ‘xrandr --help’ for more information.

P.S my laptop is a Amilo pro 2030 with the following spec and modules.
Summary

-Computer-
Processor : Intel® Celeron® M processor 1.50GHz
Memory : 1927MB (884MB used)
Machine Type : Notebook
Operating System : Ubuntu 18.04.3 LTS
User Name : james (James)
Date/Time : Tue 10 Dec 2019 11:25:32 GMT
-Display-
Resolution : 640x480 pixels
OpenGL Renderer : (Unknown)
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : VIA8237 - VIA 8237
Audio Adapter : VIA82XX-MODEM - VIA 82XX modem
-Input Devices-
Power Button
Lid Switch
Power Button
AT Translated Set 2 keyboard
AlpsPS/2 ALPS GlidePoint
Video Bus

Operating System

-Version-
Kernel : Linux 4.15.0-72-generic (i686)
Version : #81-Ubuntu SMP Tue Nov 26 12:19:40 UTC 2019
C Library : GNU C Library / (Ubuntu GLIBC 2.27-3ubuntu1) 2.27
Distribution : Ubuntu 18.04.3 LTS
-Current Session-
Computer Name :
User Name : james (James)
Language : en_GB.UTF-8 (en_GB)
Home Directory
-Misc-
Uptime : 2 hours 18 minutes
Load Average : 0.66, 0.86, 0.96
Available entropy in /dev/random : 3698 bits (healthy)

Kernel Modules

-Loaded Modules-
b43 : Broadcom B43 wireless driver
snd_via82xx : VIA VT82xx audio
bcma : Broadcom's specific AMBA driver
snd_mpu401_uart : Routines for control of MPU-401 in UART mode
gameport : Generic gameport layer
mac80211 : IEEE 802.11 subsystem
snd_via82xx_modem : VIA VT82xx modem
snd_rawmidi : Midlevel RawMidi code for ALSA.
snd_ac97_codec : Universal interface for Audio Codec '97
snd_seq_device : ALSA sequencer device management
ac97_bus
snd_pcm : Midlevel PCM code for ALSA.
pcmcia : PCMCIA Driver Services
cfg80211 : wireless configuration support
joydev : Joystick device interfaces
snd_timer : ALSA timer interface
snd : Advanced Linux Sound Architecture driver for soundcards.
input_leds : Input -> LEDs Bridge
yenta_socket
serio_raw : Raw serio driver
pcmcia_rsrc
soundcore : Core sound module
pcmcia_core : Linux Kernel Card Services
shpchp : Standard Hot Plug PCI Controller Driver
mac_hid
video : ACPI Video Driver
sch_fq_codel
sparse_keymap : Generic support for sparse keymaps
input_polldev : Generic implementation of a polled input device
parport_pc : PC-style parallel port driver
ppdev
lp
parport
ip_tables : IPv4 packet filter
x_tables : {ip,ip6,arp,eb}_tables backend module
autofs4
pata_acpi : SCSI low-level driver for ATA in ACPI mode
firewire_ohci : Driver for PCI OHCI IEEE1394 controllers
psmouse : PS/2 mouse driver
via_rhine : VIA Rhine PCI Fast Ethernet driver
firewire_core : Core IEEE1394 transaction logic
mii : MII hardware support library
sata_via : SCSI low-level driver for VIA SATA controllers
ssb : Sonics Silicon Backplane driver
i2c_viapro : vt82c596 SMBus driver
uas
pata_via : low-level driver for VIA PATA
crc_itu_t : CRC ITU-T V.41 calculations

HI James (Jimbo).

Firstly can you confirm you installed Lubuntu 18.04; I see only reference to Ubuntu in your posts.

Also I’d like specs about your video hardware. Whilst many commands can provide this information, the command I use is sudo lshw -C video (sudo to elevate privilieges, lshw or list-hardware is the command, class=video to limit the output to video hardware; an example of another command might be lspci -v -s $(lspci | grep ' VGA ' | cut -d" " -f 1) but I find the lshw easier to remember). If the detail was already provided, sorry I missed it.

The commands you used to get/list information can also be handy, as different commands present the same information slightly differently (eg. the two commands I used to list your video hardware) and knowing the command helps orient the reader to what should be expected.

Welcome to the community

Hi guiverc,

I can confirm that I am using Lubuntu 18.04.

After using lshw the following was displayed.

`*-display UNCLAIMED       
       description: VGA compatible controller
       product: CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]
       vendor: VIA Technologies, Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 01
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-2.0 vga_controller bus_master cap_list
       configuration: latency=64 mingnt=2
       resources: memory:f0000000-f3ffffff memory:d1000000-d1ffffff memory:c0000-dffff`

Thank you for the commands you’ve taugh me so far. So please keep them coming :smiley:

The “CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]” from that command tells you what your video card reports itself as to the linux kernel, the UNCLAIMED tells you the kernel didn’t know what to do with it, thus it’s ignored (why you have such low resolution).

I don’t know/remember the card; but recall S3 as really old though, I did a search using that and Ubuntu (startpage for me) and scan down for a site I ~trust

https://askubuntu.com/questions/954463/ubuntu-16-04-how-to-get-display-drivers-for-s3-unichrome-pro.

The answer given I don’t see as harmful, it exists in bionic (18.04, ie. https://packages.ubuntu.com/bionic/xserver-xorg-video-openchrome) and may fix your issue so I suggest you try it, ie.
sudo apt install xserver-xorg-video-openchrome
(I try and remember or keep a feel for the packages the command installs) then reboot and hopefully it’ll be fixed.

If it doesn’t help, just remove it (sudo apt remove xserver-xorg-video-openchrome) and you’ll be asked for confirmation. If the packages listed to be removed are the same ones (to the best of your memory) that were installed, you answer Y to actually remove them, and reboot. If you’re here - you’ll be back where you started, but I’m hoping the prior paragraph worked :slight_smile: as I saw confirmation from another user at https://ubuntuforums.org/showthread.php?t=2391978

Quick update! I fixed it just before I saw your post. I came across a ubuntu forum page, which contained someone script for a simial issue. The script contained a OpenChrome Graphical for VIA Driver.

Here are the results:

james@ubuntu:~$ sudo xrandr
    Screen 0: minimum 320 x 200, current 1024 x 768, maximum 2044 x 2048
    VGA-1 disconnected primary (normal left inverted right x axis y axis)
    FP-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
       1024x768      59.92*+

I’ll place the link below.

https://ubuntuforums.org/archive/index.php/t-485646.html

Now I do hae another issue (not including the one key on the keyboard not working, lol). The WIFI is displaying as a network card but lubuntu again is ignoring it. but I’ll leae it for now and raise another page for that.

Many thanks again for your help and your wisdom!

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.